OpenOffice does not open word documents

Asked by Andreas Saladin

Binary package hint:

OpenOffice Word Processor doesn't open word files allthough Nautilus recognizes that the file is a word document. If I add .doc at the filename it works. But doing that for all my old files I worked with on my Apple is a headache. How to better solve this and why does'nt it work anyway? I use:
Ubuntu 9.10 (karmic)
 2.6.31-22-generic (#60-Ubuntu SMP Thu May 27 00:22:23 UTC 2010)
OpenOffice 3.1.1

ProblemType: Bug
Architecture: i386
Date: Mon Jul 12 16:19:51 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: 1:3.1.1-5ubuntu1.2
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-22.60-generic
Uname: Linux 2.6.31-22-generic i686

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

This question was originally filed as bug #604637.

Revision history for this message
Andreas Saladin (andisaladin) said :
Revision history for this message
Mitch Towner (kermiac) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at if you are uncertain if they are bugs. For help on reporting bugs, see

Revision history for this message
Vu Do Quynh (vu-do-quynh) said :


I think the reason is that the file extension ".doc" has an important meaning in associating this extension with the type of application.

I took an existing .doc document file, changed its name by removing the .doc extension name and in the properties of the file (right-click > properties) the type of the file immediately changed from MS Word document (application/msword) to OLE2 (application/x-ole-storage). This is why you can't no more open the file automatically with

If you need to add the suffix ".doc" to all your word document files, you could use a mass rename utility.

Hope that helps.

Revision history for this message
Best delance (olivier-delance) said :

Do your files have a current extension to tell Apple OS it is a word file ?

Revision history for this message
Andreas Saladin (andisaladin) said :

No, Apple has no extensions - it recognizes automatically. Well luckily I can add .doc and it works it is just not fun doing so. What rename utility could help me? thanks.

Revision history for this message
Vu Do Quynh (vu-do-quynh) said :


You can go to the Ubuntu Software center (under the Applications menu) and search for "file rename". I found PyRenamer, GPrenamer, Purr and Krename. I have used PyRenamer once in the past.

If you know how, you could also write a small bash script to rename all the files in one subdirectory (you can probably find lots os such scripts on the internet).

Hope that helps.

Revision history for this message
inashdeen (inashdeen) said :

how about trying running it on a microsoft windows first. i dont kniw, never used a mac for real actually, but windows might auto put the extensions

Revision history for this message
delance (olivier-delance) said :

Run the command
    file word_filename
where word_filename is name of a word file.
If the command "file" recognize file as Word, it is possible to write a script to add ".doc" extension to all Word files.

Revision history for this message
jeffrey37 (jeff32kubbs) said :

I would suggest you next utility to repair corrupted word file application restores word files from media storages: usb, flash, network drives…