cosmic: openmpi broken (with fix)

Asked by Nico Schlömer on 2018-08-08

Right now, openmpi is broken in cosmic (with 3.1.1.real-1). Effects: Things like gmsh (which uses openmpi) don't even start.This is due to a bug known and fixed in Debian [1]. The updated version is available [2], but hasn't made it into cosmic yet. Any idea of when this will happen?

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=903561
[2] https://launchpad.net/ubuntu/+source/openmpi/3.1.1.real-4

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openmpi Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-08-08
Last query:
2018-08-08
Last reply:
2018-08-08
Manfred Hampl (m-hampl) said : #1

Cosmic is the development version. If there is something wrong with it, please create a bug report.
The question area is focusing on Ubuntu releases that are already published for general use.

It's not even in alpha 1..... What did you expect?

If you want an OS that works then I suggest you wipe the install off and do a clean install of Bionic. Bionic is LTS and supported until April 2023.

If you want to report bugs and don't mind bugs and feature holes then by all means use Cosmic but don't expect a smooth ride.

Nico Schlömer (nschloe) said : #3

> What did you expect?

It's okay that it breaks, I just wanted to let you know that this needs updating before the Debian Import Freeze on Aug 23 (in two weeks).

Manfred Hampl (m-hampl) said : #4

If "you" are the developers, then you have to use the bug tracker, not answers.launchpad.net

Nico Schlömer (nschloe) said : #5

Ah, I though this was the bug tracker!

Where do I find it?

Best Manfred Hampl (m-hampl) said : #6

This is https://answers.launchpad.net/ubuntu/+source/openmpi and the bug tracker is https://bugs.launchpad.net/ubuntu/+source/openmpi

They are interlinked, so you can navigate from one to the other with the links in the heading, and you can also create a bug report simply by using the "Create bug report" link above the message box in this document:

https://answers.launchpad.net/ubuntu/+source/openmpi/+question/671423/+makebug

Nico Schlömer (nschloe) said : #7

Thanks Manfred Hampl, that solved my question.