Fix for openldap ITS#6540 in Ubuntu slapd package

Asked by Khosrow Ebrahimpour on 2011-03-09

Hi,

I am running a 10.04 LTS server with slapd 2.4.21-0ubuntu5.3. I've ran into an issue involving slapo-chain and referral chasing and I've traced it back to ITS #6540 in openldap. The issue has been fixed in the main trunk as of April 29, 2010 but I am not sure if it was captured for the 10.04 packages.

Is there a way to confirm this? (A quick search of the chagelogs for the various slapd package didn't turn anything up.)

Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openldap Edit question
Assignee:
No assignee Edit question
Solved by:
Khosrow Ebrahimpour
Solved:
2011-03-10
Last query:
2011-03-10
Last reply:
2011-03-09

So you want a newer version, is that the fix?

No, I'd like to know if it has already been incorporated in any of the "slapd" packages provided by Ubuntu. I already did a search of the changelogs using http://www.google.com/#sclient=psy&hl=en&q=site:changelogs.ubuntu.com%2Fchangelogs%2Fpool%2Fmain%2Fo%2Fopenldap+6540
and didn't find anything.

There's no mention of that ITS in the changelogs like I had mentioned earlier.

Are you implying that because this package was released after the patch was submitted to OpenLDAP CVS, then it is included in the package?

So it turns out that the patch was actually committed sometime in November 2010. After doing some more searching, the fix is included in OpenLDAP 2.4.24:
http://www.openldap.org/lists/openldap-announce/201102/msg00000.html

And for the time being there's no package in lucid-backports for that version.