Is thisJDK-8145388 JPG/MIME Type bug in Ubuntu

Asked by janpopan on 2020-05-05

Hi,

I think this JDK-8145388 is a part of ubuntu 16.04.

I try to convert svg files with integrated jpeg streams to png.

Windows:
Amazon Coretto 8 (222/232/242) ->Tomcat-> batik 1.12 -> works

Ubuntu 16.04 LTS
default+lates OpenJDK from Ubuntu 16.04 ->Tomcat-> batik 1.12 -> unsupported Type while converting the integrated jpeg

Ore some other idea?

thanks Jan

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openjdk-8 Edit question
Assignee:
No assignee Edit question
Solved by:
janpopan
Solved:
2020-05-23
Last query:
2020-05-23
Last reply:
2020-05-06

Have you tried Oracle Java in Ubuntu. The WebUpd8 guys have a PPA to easily install it

Saya baru saja menemukan blog Anda dan ingin mengatakan bahwa saya benar-benar menikmati posting blog Anda. Bagaimanapun, saya akan berlangganan dengan Anda dan saya harap Anda segera menulis lagi.

http://202.95.10.147
http://www.qiu9qiu9.com/

janpopan (janpopan) said : #3

Now we tried Amazon Coretto 8 latest build an it works.

I beleive the problem is the version of libjpeg-turbo (1.4.2) wich is bundled with the openjk in ubuntu 16.04 lts.

The Problem with "my" jpegs as fixed with libjpeg-turbo 2.0.0.

https://github.com/libjpeg-turbo/libjpeg-turbo/releases

"Significant changes relative to 2.0 beta1:

    The TurboJPEG API can now decompress CMYK JPEG images that have subsampled M and Y components (not to be confused with YCCK JPEG images, in which the C/M/Y components have been transformed into luma and chroma.) Previously, an error was generated ("Could not determine subsampling type for JPEG image") when such an image was passed to tjDecompressHeader3(), tjTransform(), tjDecompressToYUVPlanes(), tjDecompressToYUV2(), or the equivalent Java methods."

Cheers Jan

If you can, report a bug to get the issue resolved please. If it's a simple update to the package(s) then awesome. Should make things smoother for other users. Great share in the meantime. Hopefully it'll help others