missing openjdk-7-jdk-headless in xenial packages

Asked by MANIK on 2016-04-26

We do not have any package of openJdk 7 for xenial.

Link Referred:- http://packages.ubuntu.com/xenial/java/

Could you suggest if we are in process of adding packages

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openjdk-8 Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2016-04-27
Last query:
2016-04-27
Last reply:
2016-04-27
daniel CURTIS (anoda) said : #2

Hello MANIK. It seems, that openJdk 7 is/was available only for: precise, precise-updates, trusty, trusty-updates, wily and wily-updates releases [1]. If it's about Xenial Release there is openjdk-8-jdk (latest version: 8u77-b03-3ubuntu3, Published on 2016-04-14) [2]. So, You should install openjdk-8 or try to install older version openjdk-7-jdk etc.

Best regards.
_____________
[1] http://packages.ubuntu.com/wily-updates/openjdk-7-jdk
[2] openjdk-8-jdk, amd64 binary, package for Xenial: https://launchpad.net/ubuntu/xenial/amd64/openjdk-8-jdk/8u77-b03-3ubuntu3 (WARNING: please note architecture; here is amd64! If You're using e.g. i386 etc., please check this link: https://launchpad.net/ubuntu/xenial/+source/openjdk-8 and "Binary packages").

MANIK (smanik-im) said : #3

Hey Daniel

Yes, Its about Xenial.
I saw opnjdk-8 there and don't want to upgrade as of now.

Does it mean that we will not be releasing jdk 7 package for this

Regards
Manik Singla

Best Manfred Hampl (m-hampl) said : #4

Yes, see Bug #1563986

MANIK (smanik-im) said : #5

Thanks Manfred Hampl, that solved my question.