openjdk-7 broken packages on ubuntu 16.04 LTS

Asked by Battant on 2016-04-23

Hello,

Here is my configuration :
lsb_release -rd
Description: Ubuntu 16.04 LTS
Release: 16.04
uname -a
Linux mparchet-W240EU-W250EUQ-W270EUQ 4.4.0-18-generic #34-Ubuntu SMP Wed Apr 6 14:01:02 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
package affected :

apt-cache policy openjdk-7-jre
openjdk-7-jre:
  Installed: (none)
  Candidate: 7u95-2.6.4-1
  Version table:
     7u95-2.6.4-1 500
        500 http://archive.ubuntu.csg.uzh.ch/ubuntu xenial/main amd64 Packages

The install result :
apt-get --simulate install openjdk-7-jre
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u95-2.6.4-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Expanded result :
 openjdk-7-jre install successfully

Could you help me please to fix this issue ?

Best regards

Battant

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu openjdk-7 Edit question
Assignee:
No assignee Edit question
Last query:
2016-04-23
Last reply:
2016-04-23
Battant (mparchet) said : #1

Noe :openjdk-7-jre is necessary to run eclipse mars :

download link :

https://www.eclipse.org/downloads/packages/release/Mars/2

Manfred Hampl (m-hampl) said : #2

openjdk-7 is no more provided with Ubuntu xenial, see also Bug #1563986

I am astonished to see this package still offered by your repository server, This might be another indication that that repository server has got problems and is not up-to-date.
I strongly advice that you select a different repository server.

Can you help with this problem?

Provide an answer of your own, or ask Battant for more information if necessary.

To post a message you must log in.