howto disable gtk look of swing apps?

Asked by bak1an on 2009-03-24

have created with "swing.defaultlaf=javax.swing.plaf.metal.MetalLookAndFeel" at /usr/lib/jvm/java-6-openjdk/, but it does not help. so how can enable default swing look in ubuntu?

Question information

English Edit question
Ubuntu openjdk-6 Edit question
No assignee Edit question
Last query:
Last reply:
Craig Huffstetler (xq) said : #1

This is an "at your own risk" type of issue. It has been reported as a "Wishlist Bug" item ( ) and developers know about it. However, I am only pointing you in the risk directly.

Depending on the version of Ubuntu you are running this may help you or you may benefit from it if you are a developer-type:

I wish I could offer more guidance, however I understand your frustration.


bak1an (antonbaklanov) said : #2

# ls -l /usr/lib/jvm/java-6-openjdk/jre/lib/
lrwxrwxrwx 1 root root 36 2009-03-14 23:39 /usr/lib/jvm/java-6-openjdk/jre/lib/ -> /etc/java-6-openjdk/

# cat /etc/java-6-openjdk/

$ java -version
java version "1.6.0_0"
IcedTea6 1.3.1 (6b12-0ubuntu6.1) Runtime Environment (build 1.6.0_0-b12)
OpenJDK Client VM (build 1.6.0_0-b12, mixed mode, sharing)

but i still see gtk look of swing apps. Craig, thanks for your reply, but i just want enable metal-laf, instead of that crappy gtk-laf ( here peoples wanna GTK instead of metal by default), what is the "risk" you wrote about? i don't use GIJ and any patches for "Mac-style shit".

Can you help with this problem?

Provide an answer of your own, or ask bak1an for more information if necessary.

To post a message you must log in.