No installation without Java possible

Asked by Heimen Stoffels on 2011-09-15

When you remove OpenJDK, Sun Java comes in. And when you then remove Sun Java again, OpenJDK pulls in.
Why should that be dependent on each other? It must be possible to have an install without Java, like when you for example remove Firefox, no other browser comes in. When you remove Flash Player, no other flash player comes in.
Then why not make it possible to have a system without Java?

Question information

Language:
English Edit question
Status:
Needs information
For:
Ubuntu openjdk-6 Edit question
Assignee:
No assignee Edit question
Last query:
2011-09-18
Last reply:
2011-09-18

This question was originally filed as bug #851232.

This question was reopened

Heimen Stoffels (vistaus) said : #1

If I do apt-get remove openjdk-6-jre-headless, nothing gets removed at all.

Heimen Stoffels (vistaus) said : #2

Sorry if I didn't make myself clear, but this happens on 11.10
I have tried everything possible including your suggestion of openjdk-6-jre-headless removing, but nothing lets me get an install without Java. So please make this a bug again, 'cause it needs to be addressed as an dependency-failure.

You don't have to have any Java runtime installed. But every Java program depends disjunctively on the available Java runtimes, so you must remove them too (or force them to be installed without their dependencies) in order to remove Java. If you try simulating the removal of all available Java runtimes (including ones not installed) that should tell you what is depending on them. It might be OpenOffice.org/LibreOffice.

I don't have access to an Ubuntu machine at the moment, but a command like this should do the trick for revealing that information:

apt-get -s remove sun-java6-jre openjdk-6-jre

If you have any more trouble, please post another reply requesting further assistance.

Heimen Stoffels (vistaus) said : #4

I don't have LibreOffice installed and that command doesn't list any package.

Heimen Stoffels (vistaus) said : #5

Huh why it's marked as solved all of a sudden o_o

"I don't have LibreOffice installed and that command doesn't list any package."

Can you provide the full output of the command, so I can see what I (probably) got wrong?

"Huh why it's marked as solved all of a sudden o_o"

Did you click the "This Solved My Problem" or "Problem Solved" button?

OK, I now am sitting at an Ubuntu machine. It is running Oneiric, so it is perhaps different from your system in highly relevant ways. When I simulate the removal of openjdk-6-jre, no other packages are (simulated as being) added or removed. So it is especially important that you post the full output of the command given above, to help figure out what is different about your configuration that is causing you difficulty in eliminating Java.

Can you help with this problem?

Provide an answer of your own, or ask Heimen Stoffels for more information if necessary.

To post a message you must log in.