How to remove/uninstall an jnlp(javaws) application?

Asked by Farley Lai on 2010-10-12

The option -uninstall described in the manual page seems not to work.
If I invoke javaws directly, only a certificates management window shows instead of an application management window.
How do I remove/uninstall an jnlp(javaws) application?

PS:
Platform: Ubuntu 10.10

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu openjdk-6 Edit question
Assignee:
No assignee Edit question
Last query:
2010-10-13
Last reply:
2015-04-14
marcus aurelius (adbiz) said : #1

how was it installed?

if you used "dpkg -i [pkg-name]" to install it, you uninstall it with "dpkg --remove [pkg-name]"

if you installed it via synaptic package manager, you can remove it from there by searching for the name then clicking on the green box that pops up beside it.

Farley Lai (farleylai) said : #2

I installed a java web start application by "javaws xyz.jnlp" but "javaws -uninstall xyz.jnlp" doesn't remove the application.
I did not use synaptic pkg manager.

marcus aurelius (adbiz) said : #3

okay. i did some searching on google. have you done that yourself?????
it seems that a lot of people are having problems uninstalling javaws stuff. there are some solutions. have you tried those?

Farley Lai (farleylai) said : #4

I used to install/uninstall java web start applications years ago on Windows. It's simple because invoking javaws itself should bring out an application management window. However, it's never the case with openJDK. Of course, I surveyed the web but failed to find an officially suggested solution. So ultimately I tried a brutal procedure: digging out where the installed .jar is by listing all the hidden directories in my HOME. Then the result follows:

1. manually remove the package including the jars in ".netx/cache/"
2. manually remove config or *.userPrefs associated with the installed package in .java/
3. invoke javaws and remove the accepted certificates of the package

I'm not sure if that's all to clean up the installed application.

marcus aurelius (adbiz) said : #5

you can always remove javaws and openjdk completely, purge the system, then reinstall it if you MUST have it. i read that newer versions aren't compatible with older versions, thus the inability to uninstall apps.

liu (liuzhongjun) said : #6

As I observed and tried out, the javaws installation is just temporarily kept in cache. All you need to do is to launch configure Java, and swipe out all cache. You'll have nothing in your instalation any more.

liu (liuzhongjun) said : #7

Now I tested both under Windows 7 and Ubuntu 14.04.2:

Really Javaws is just caching the application on the local computer, you just need to delete Files and applications here:

Java Control panel -> General -> Temporary Internet Files -> Settings -> Delete Files, don't forget to mark "Installed Applications and Applets".

I did this with OmegaT, and it's successful. I decide not to use javaws, because it's much slower than a normal application and for the configuration, it's not convenient at all with OmegaT.

Enjoy.

Can you help with this problem?

Provide an answer of your own, or ask Farley Lai for more information if necessary.

To post a message you must log in.