dpkg: dependency problems prevent configuration of python-opencv:

Asked by sam on 2018-10-02

python-opencv depends on libopencv-calib3d3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-calib3d3.1 is not installed.
 python-opencv depends on libopencv-features2d3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-features2d3.1 is not installed.
 python-opencv depends on libopencv-flann3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-flann3.1 is not installed.
 python-opencv depends on libopencv-highgui3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-highgui3.1 is not installed.
 python-opencv depends on libopencv-imgcodecs3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-imgcodecs3.1 is not installed.
 python-opencv depends on libopencv-imgproc3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-imgproc3.1 is not installed.
 python-opencv depends on libopencv-ml3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-ml3.1 is not installed.
 python-opencv depends on libopencv-objdetect3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-objdetect3.1 is not installed.
 python-opencv depends on libopencv-photo3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-photo3.1 is not installed.
 python-opencv depends on libopencv-shape3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-shape3.1 is not installed.
 python-opencv depends on libopencv-stitching3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-stitching3.1 is not installed.
 python-opencv depends on libopencv-superres3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-superres3.1 is not installed.
 python-opencv depends on libopencv-video3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-video3.1 is not installed.
 python-opencv depends on libopencv-videoio3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-videoio3.1 is not installed.
 python-opencv depends on libopencv-videostab3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-videostab3.1 is not installed.
 python-opencv depends on libopencv-viz3.1 (= 3.1.0+dfsg1-1~exp1ubuntu3); however:
  Package libopencv-viz3.1 is not installed.
 python-opencv depends on libopencv-contrib3.1; however:
  Package libopencv-contrib3.1 is not installed.
 python-opencv depends on libopencv-core3.1; however:
  Package libopencv-core3.1 is not installed.

following are the dependencies I am unable to install them. how do I proceed, I have googled for this but no answers

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu opencv Edit question
Assignee:
No assignee Edit question
Last query:
2018-10-02
Last reply:
2018-10-17
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes please provide the output of the commands

uname -a
lsb_release -crid
apt-cache policy python-opencv libopencv-calib3d3.1

Launchpad Janitor (janitor) said : #2

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.