openafs : klog : RPC error : can't parse principal name

Asked by llexpress

I've just installed Intrepid along with openafs 1.4.7.dfsg1-6 (from the Intrepid repos) I have the following kernel version:

$ cat /proc/version
Linux version 2.6.27-11-generic (buildd@rothera) (gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu11) ) #1 SMP Thu Jan 29 19:24:39 UTC 2009

I configured the /etc/openafs/CellServDB and /etc/openafs/ThisCell with the appropriate information and compiled the kernel module as per the openafs instructions. I am able to start the openafs client without a problem:

$ sudo /etc/init.d/openafs-client restart
Stopping AFS services: afsd openafs.
Starting AFS services: openafs afsd.
afsd: All AFS daemons started.

The problem shows up when I try to obtain tokens:

$ klog
klog: unknown RPC error (-1765328160) Can't parse principal <username>

I have the exact same setup on multiple Hardy installations with openafs 1.4.6.dfsg1-2 and kernel:
$ cat /proc/version
Linux version 2.6.24-23-generic (buildd@vernadsky) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Mon Jan 26 00:13:11 UTC 2009

My Hardy installations are all working fine.

I've been searching across the internet for some pointers but haven't found anything. Does anyone have any ideas?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu openafs Edit question
Assignee:
No assignee Edit question
Solved by:
steve.rueg
Solved:
Last query:
Last reply:
Revision history for this message
Best steve.rueg (steve-rueg) said :
#1

I had the same problem and the same Ubuntu setup. A colleague sent me the link below. For Intrepid, I used "klog.afs" rather than "klog" and was able to get a token.

(Note, I also had to 'sudo /etc/init.d/enafs-client force-start' before getting a token.)

http://ibmforums.ibm.com/forums/message.jspa?messageID=1536259#1536259

Hope this helps,
Steve

Revision history for this message
llexpress (llexpress) said :
#2

Thanks steve.rueg, that solved my question.