Can open-vm-tools replace the VMware Tools for Kubuntu 14.10 (The Utopic Unicorn)?

Asked by Marco Parillo on 2014-07-08

I normally use the VMware Player "Easy Install" for Kubuntu (and other flavors), but for some reason it seems to hang on Kubuntu 14.10 Alpha 1. So I tried the install later and then installing VMware Tools manually (the way I have to for NetRunner), and that seemed to hang also. But on Fedora, there is an open-vm-tools package, which I had never heard of before, so I tried it in Kubuntu 14.10. It seemed to install smoothly, but the full screen mode does not work (that is my display stays small). Should this work (in other words, is it a bug), or am I missing the point of this package on Ubuntu.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu open-vm-tools Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2014-07-08
Last query:
2014-07-08
Last reply:
2014-07-08

Probably because it's in Alpha. It is not even remotely ready and not stable. If you want an OS that works then I suggest you use Trusty. Trusty is also LTS and Utopic isn't giiving Trusty a significantly longer support length.

Marco Parillo (marco-parillo) said : #2

Thank you actionparsnip. I guess I was asking whether it made sense to raise a bug report so it can be fixed by October, or to better understand if this package is not intended to do what I am trying to do (that is, it is not a bug at all).

Yes raise a bug, the OS is half made at best

Marco Parillo (marco-parillo) said : #4

Thanks actionparsnip, that solved my question.

Marco Parillo (marco-parillo) said : #5

Thank you. I created Related Bug #1338993: Full Screen Mode does not work with open-vm-tools and Kubuntu 14.10

Marco Parillo (marco-parillo) said : #6

open-vm-tools by itself cannot, but it can if you also install:
sudo apt-get install open-vm-tools-desktop

I found it suggested on: http://packages.ubuntu.com/trusty/open-vm-tools
Description: Open VMware Tools for virtual machines hosted on VMware (GUI)v