Onboard focus with KWin

Asked by Jackson Wiegman on 2015-06-30

Customized Ubuntu 15.04, running KWin via an .xsession call. Using Onboard for on-screen keyboard. The keyboard won't get focus unless I tap on it twice (or unless I drag into the keyboard, and then tap it). In my previous environment I used Compiz and didn't have this behaviour, nor do I see it with any other window type.

Turning debugging on for Onboard it seems to be getting the touch events so I am not sure why its not getting focus. Its output for example would be:

Code: Select all
19:23:08.392 EVENT TouchInput Source device: XIDevice(id=13 attachment=2 use=3 touch_mode=1 source=GDK_SOURCE_TOUCHSCREEN name=SYNA7500:00 06CB:3AF0 vendor=0x06cb product=0x3af0 enabled=1)
19:23:08.392 EVENT TouchInput _on_device_event1
19:23:08.393 EVENT TouchInput _on_device_event2 2 2
19:23:08.393 EVENT TouchInput _on_device_event7 1
19:23:08.393 EVENT TouchInput _on_device_event8 True
19:23:08.393 EVENT TouchInput _on_device_event10 20971528 20971707
19:23:08.393 EVENT TouchInput _on_device_event11
19:23:08.394 EVENT TouchInput Device event: dev_id=2 src_id=2 xi_type=7 xid_event=20971528(20971707) x=171.0 y=45.0 x_root=1642.0 y_root=405.0 button=0 state=0 sequence=0

A little lost and looking for any suggestions!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu onboard Edit question
Assignee:
No assignee Edit question
Last query:
2015-06-30
Last reply:
2015-07-01

I suggest you report a bug. Have you tried other keyboards?

Jackson Wiegman (jackson-e) said : #2

I loaded gnome-desktop on my image, the gnome keyboard worked fine, the Onscreen still had the same issue... but looks like its working ok with mouse events, so this appears to be a touch issue. I'll file a bug.

Can you help with this problem?

Provide an answer of your own, or ask Jackson Wiegman for more information if necessary.

To post a message you must log in.