cannot install offlineimap

Asked by Jacob Steringa on 2019-01-04

I can't install offlineimap because the required dependency python-imaplib2 breaks because of an update of libssl1.1. Is there a way to fix this or is the offlineimap package broken?

uname -a:
Linux jacobdubbel 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -crid:
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

sudo aptitude install offlineimap:

De volgende NIEUWE pakketten zullen worden geïnstalleerd:
  offlineimap python-imaplib2{a}
0 pakketten opwaarderen, 2 nieuwe installeren, 0 te verwijderen en 0 niet ge-upgrade.
Heb 157 kB archieven nodig. Na uitpakken zal 714 kB worden gebruikt.
De volgende pakketten hebben niet-voldane vereisten:
 libssl1.1 : Breekt: python-imaplib2 (< 2.57-5) maar 2.57-1 zal geïnstalleerd worden
De volgende acties zullen deze vereisten oplossen:

     Behoud de volgende pakketten op hun huidige versie: KEEP CURRENT
1) offlineimap [Niet geïnstalleerd]
2) python-imaplib2 [Niet geïnstalleerd]

Deze oplossing aanvaarden? [Y/n/q/?]

Deze oplossing aanvaarden? [Y/n/q/?] n
De volgende acties zullen deze vereisten oplossen:

     Degradeer de volgende pakketten: DOWNGRADE
1) libssl-dev [1.1.1a-2+ubuntu18.04.1+deb.sury.org+1 (bionic, now) -> 1.1.0g-2ubuntu4.3 (bionic-security, bionic-updates)]
2) libssl1.1 [1.1.1a-2+ubuntu18.04.1+deb.sury.org+1 (bionic, now) -> 1.1.0g-2ubuntu4.3 (bionic-security, bionic-updates)]
3) openssl [1.1.1a-2+ubuntu18.04.1+deb.sury.org+1 (bionic, now) -> 1.1.0g-2ubuntu4.3 (bionic-security, bionic-updates)]

Deze oplossing aanvaarden? [Y/n/q/?]

The aptitude output is in dutch, but I hope it will be helpfull. I added the proposed action in english above the packages and versions.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu offlineimap Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-01-04
Last query:
2019-01-04
Last reply:
2019-01-04

What is the output of:

apt-cache policy offlineimap

Thanks

Jacob Steringa (jacobsibben) said : #2

That would be this:

offlineimap:
  Geïnstalleerd: (geen)
  Kandidaat: 7.1.5+dfsg1-1
  Versietabel:
     7.1.5+dfsg1-1 500
        500 http://nl.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        500 http://nl.archive.ubuntu.com/ubuntu bionic/universe i386 Packages

Thanks

Best Manfred Hampl (m-hampl) said : #3

The root cause of your problem is that you have installed libssl1.1 from a PPA (probably ppa:ondrej/apache2), and that version seems to be incompatible with python-imaplib2 (which is required for offlineimap).

Aptitude already made proposal how to correct this - downgrade libssl-dev, libssl1.1 and openssl to the version delivered in the standard Ubuntu repositories.
I do not know for which purpose you have added the PPA; so I cannot judge what effects this downgrade would have on other packages that you have installed.

Another potential way to solve the problem could be to install a python-imaplib2 version 2.57-5 package on your system. The package for cosmic might be a good candidate.

Jacob Steringa (jacobsibben) said : #4

Thanks Manfred,

Totally missed that. I tried downgrading and everything is working.

I use ppa:ondrej/php to have multiple php versions available, but php seems to be working fine with libssl1.1.0 from the default repositories.

Jacob Steringa (jacobsibben) said : #5

Thanks Manfred Hampl, that solved my question.