boot problem in Ubuntu server 16.04.2 LTS

Asked by Ohuajo on 2017-02-23

I just installed ubuntu server 16.04.2 LTS on HP proliant server. It only boot to tty1 through recovery mode, else it will just be black (no command prompt).
I have changed the GRUB_CMLDLINE_LINUX_DEFAULT="" in the /etc/default/grub to GRUB_CMLDLINE_LINUX_DEFAULT="text" yet it still doesnt work. Looking forward to assistance on this.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Solved by:
Ohuajo
Solved:
2017-02-24
Last query:
2017-02-24
Last reply:
2017-02-23

Does the system have a make and model?
What video chip does it use?

Details please.....

Ohuajo (ohuajo) said : #2

Thanks, it is HP ProLiant DL380 G7 2 x 2.40Ghz E5645 Six Core 48GB.
"lshw -c video" shows "product:ES1000"
Also pls note that I installed the OS without Internet; now I have access to internet, do I have to install/update any driver? If yes, pls explain how to do it as I am a novice(coming from GUI background).

Run full updates. This may help

Ohuajo (ohuajo) said : #4

Thanks, it did not help. I can only still connect by getting to advance option and then recovery mode and then resume normal boot. After update and upgrade I now have four options (repeat of the previous two options in the advance option)
I also have the another problem, every time I reboot, to connect to internet I have to always do "sudo dhclient" to be able to connect to internet (ie iconfig will not show IP address, neither will sudo apt-get update work)

Ohuajo (ohuajo) said : #5

To solve the "sudo dhclient" issue I have added "sudo dhclient enp3s0f0" before exit0 in /etc/rc.local.

The boot problem is still the problem, any help?

Did you set:

auto enp3s0f0
iface enp3s0f0 inet dhcp

In /etc/network/interfaces

That's the usual way...

Ohuajo (ohuajo) said : #7

No, I did not edit /etc/network/interfaces
 Editing /etc/rc.local by adding "sudo dhclient enp3s0f0" before "exit0" solved the internet connection problem

Ohuajo (ohuajo) said : #8

At last I am able to boot directly into ttyy1 without going through the recovery mode. I had to install amdgpu-pro by downloading the driver from http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx in another computer (using wget produced a tar.xz file that was not decompress-able) and ssh the resulting folder to my home folder. I then:
cd amdgpu-pro-16.60-379184
./amdgpu-pro-install -y

Reboot and .........

bingo