Desktop appear and disappear

Asked by alessandro fabbrini on 2013-01-30

I had 10.4 LTS version and upgraded to 12.10 release using update manager. Everything was good, no problems or errors during the upgrade.
I reboot my laptop, found a new grub system (normal thing, i have win7 too) that lead me to a new login page.
Login goes well, but then i see strange things. My desktop appear and disappear, sometimes there are icons on it, sometimes there's only the wallpaper. Sometimes the screen is covered by strange large images like smiles and stars. No application bar or cairo-dock appears. I can call the shell with the keyboard, but it appears and disappear with the desktop. I tried to write commands into it and it works, but when asks me for the sudo password i just can't type it correctly because of the lag.
I think this is a graphic problem but i have no idea how to fix it.
The only thing i can do is logout with ctrl+alt+canc and go back to the login screen, that is correctly displayed .

I thought that the cause was my laptop, since it's quite old. I have an AMD Turion 64X2 (1,60 Ghz) Processor, 2,50 GB RAM and a nvidia GeForce GO 6150 (125 MB) graphic card.

I tried the Lubuntu live cd to verify if it's an hardware problem. It's going the same. Instead of the desktop, I see horizontal lines, black screen and other stuff like this.

I really can't understand what is happening. I had no graphic problems before the upgrade.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-30
Last reply:
2013-01-31
N1ck 7h0m4d4k15 (nicktux) said : #1

Try to re-install nvidia-graphics driver. With CTRL+ALT+F1 your will be reverted to Console Mode (no Desktop Environment)

There login with username & password and execute all the commands below , one by one..

sudo service lightdm stop
sudo apt-get install --reinstall nvidia-current nvidia-settings
sudo nvidia-xconfig
sudo dpkg --configure -a
sudo apt-get install -f
sudo reboot

Last command will reboot your system and see if problem solved.

IF NOT

then post back here the results of commands

1) dpkg -l | grep -i nvidia

2) lsb_release -rcd ; uname -r

3) lspci -nnk | grep -iA2 vga

Thanks

Try to re-install gnome-pannel if #1 don`t work:

sudo apt-get uninstall gnome-panel

then: ctrl+alt+T

and:

sudo apt-get install gnome-panel

Can you help with this problem?

Provide an answer of your own, or ask alessandro fabbrini for more information if necessary.

To post a message you must log in.