Ubuntu only boots through "recovery mode"

Asked by Filipp on 2012-05-24

When I select normal boot item in grub menu, according to kernel log the boot continues, but display just shows background of grub selection window. Like this:
http://www.youtube.com/watch?v=_P9-1GDXaWI
When I select recovery mode and then proceed normal boot, everything boots fine:
http://www.youtube.com/watch?v=-1Y0dGG-gS4

Issue appeared after I switched my Nvidia 8600 GT to NVidia GeForce GTX 550 TI.

If you look at the diff of kernel logs you can see that in recovery mode it sees console as VGA+ and in normal mode as "dummy device:" http://diffchecker.com/AmzGV590

Ubuntu 12.04, upgraded.
Issue was in 11.10 and wasn't fixed by upgrading.

What should I do with grub to make it load in normal mode?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Solved by:
Filipp
Solved:
2012-06-16
Last query:
2012-06-16
Last reply:
2012-05-24

Uninstall the nvidia driver, boot to the desktop and then reinstall the driver. You may need to add the boot option:

nouveau.blacklist=1

Filipp (samoylovfp) said : #2

Unfortunately neither did help. I really think that grub is to blame since the picture doesn't change at all after its OS selection menu.

Hold shift at boot and you can add boot options

Filipp (samoylovfp) said : #4

I holded shift at both boots - nothing changed. I've added boot options in /etc/grub/default and then performed update-grub. Still only pink rectangle after selecting normal boot item

John Reinert (jreinert2014) said : #5

I have the same graphics card and the same problem. I can only access Ubuntu by going through the recovery mode and then choosing resume.

Filipp (samoylovfp) said : #6

After some updates suddenly it started working. Unfortunatelly I can't tell you exactly after which, because I discovered that it works by accident

David Robert Lewis (afrodeity) said : #7

I also have this issue for some reason, black screen unless I boot via recovery mode in 12.04

tad1073 (tad1073) said : #8

I'm experiencing the same thing, not black screen but the purple background that grub uses when I boot normaly.

tad1073 (tad1073) said : #9

Oh, and how was this solved?

professorgraham (ricky-9) said : #10

I also have the same issue. I am running dual boot (OSX, Linux) on a Macbook i7 2.3 GHz Intel Core i7. Graphics card is Intel HD Graphics 4000 384 MB/NVIDIA GeForce GT 650M. I am using rEFTIt as my bootloader. I can only access Ubuntu 12.10 through recovery mode also. When trying to load directly from the bootloader, I never get passed the purple screen, sometimes a black screen with blinking cursor key too.

I have updated to the latest version of Ubuntu 12.10. Everything else seems to be working fine. Any ideas on how to resolve this? What were the updates installed to overcome this problem? Where they general Ubuntu updates?

switchable video chips get support with bumblebee. it is far from perfect but does work. i recommend avoiding switchable gpus if you can

professorgraham (ricky-9) said : #12

I am new to Ubuntu and have no experience with "bumblebee."

I found the following: https://wiki.ubuntu.com/Bumblebee

I presume if I follow this, all should be well?

Also, how do I avoid switchable GPUs? Given that this is my only machine, perhaps I cannot?

Thanks for your help, Andrew.

professorgraham (ricky-9) said : #14

Hi Andrew,

Bumblebee worked! All the best.

Ricky

My problem solved also by installing Nvidia propritary driver -- would only boot in recovery mode after installing 14.04 64 bit