Ubuntu 12.04 During boot hangs on purple screen

Asked by Nate on 2012-05-20

So when I went to restart my computer, Ubuntu froze on the purple splash screen with the red dots. I wait for a while (about 20 min) and nothing happens. I've tried manual shutdown -> then restart, but can't make it past the purple screen. Right now I am using a live cd to boot so I can access the internet.
Before this happened I changed some settings to the display. Display settings have given me a little trouble in the past but nothing like this (just thought I'd mention it)

The machine I'm using: http://www.msimobile.com/level3_productpage.aspx?id=222

Also, I am not running any other OS's alongside Ubuntu.
Anyone have any suggestions on what I can do? I am really trying to avoid a fresh install.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-20
Last reply:
2012-05-21
Barry Drake (b-drake) said : #1

Have you tried altering the setting from Unity 3D to Unity 2D at the login screen? Do you know what display settings you changed?

Nate (mrnatelantz) said : #2

I was in the gnome classic without effects de. I was changing the settings of the displays via nvidia's server setting manager. Reason was I was connection g to a TV and needed Ubuntu to recognize the TV as a display (wouldn't work in the settings -> display panel) . So I tried to install Ubuntu alongside Ubuntu hoping I could recover through the second install.
Now at the grub menu I have two options for Ubuntu (expected) and when attempt to boot into the original Ubuntu it works, BUT its only CLI, NO GUI. I know very little at the terminal so this is kinda hard for me to work with. I think the problem lies with the nvidia driver.

Nate (mrnatelantz) said : #3

The exact settings I changed were in the nvidia manager. I added a Tv as a display and disabled my monitor(laptop). Clicked apply, and achieved desired change (did not save x settings). After done watching my show I returned all display settings back to original, and clicked apply (everything seemed to be just fine). Then went to reboot, and that's when the problem started. thats why I think it has something to do nvidia.

Try the boot option:

nouveau.blacklist=1

Seems to be a GeForce® 8200M

Nate (mrnatelantz) said : #5

Ya that's actually what I had to use to install 12.04 . I couldn't fix it, but I needed my computer to work in a hurry, and was able to save my data so I ended up doing a clean install. Hopefully this nvidia thing gets fixed in the future. Should I report as a bug?

Sure, why not. Some chips hate the nouveau driver so blacklisting is necessary. I use a 6150LE with a 32" Toshiba screen and it works with the nouveau driver, depends on hardware really.

Can you help with this problem?

Provide an answer of your own, or ask Nate for more information if necessary.

To post a message you must log in.