[Ubuntu 12.04] Unity 2-D Dash Resizing Problems

Asked by Michael Elliott on 2012-05-14

Recently put Ubuntu 12.04 on my external drive and i am a complete newcomer to Linux as a whole, bar some basic command line work in Redhat8 - and i mean very, very basic.

Issue: I cannot resize my Unity 2D Dash.

I have downloaded both MyUnity and another Config tool, attempted to change the settings between 'Automatic', 'Desktop' and 'Netbook' to no effect. Even the 'Windowed Mode' icon fails to collapse it to anything less than fullscreen.

I think that it's possible that my resolution is a little low, but i'm unsure on how to change this.

I'd rather not have to play about in the Terminal if possible, not particularly comfortable changing system files as i have next to no experience.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Elliott
Solved:
2012-05-14
Last query:
2012-05-14
Last reply:
2012-05-14
Sam_ (and-sam) said : #1

Try logout-in after adjusting dash form-factor.
http://askubuntu.com/questions/68788/how-can-i-resize-the-unity-dash

Also test if the behaviour remains on guest account.
## Logout, select 'guest', hit [Enter]-key, no pw required.

In case review bug reports if there is already a bug reported by click on 'Bugs' on top of this page.
Otherwise report a new one.
https://help.ubuntu.com/community/ReportingBugs

It's expected that resolution is automatically recognized.
Please open
system-settings - displays and try to adjust as preferred.
Example image of 'displays' there.
http://askubuntu.com/questions/32249/monitor-not-detected-so-i-have-a-resolution-problem

Sam_ (and-sam) said : #2

Hi there Sam_, thanks for taking the time to reply.

Unfortunetly, none of the supplied solutions worked, i'll go through the solutions you provided and detail them.

[Solution 01]: Try logout-in after adjusting dash form-factor.

Tried changing the options in both MyUnity and Dconf (Which was the second program i mentioned previously) seperately and then logging in/out to no avail.

This was also done on the Guest account with no result.

[Solution 02]: Resolution.

Ubuntu, for some reason, has limited my maximum resolution to 1024x768 (4:3). In Windows 7, my default resolution is set higher, i can't remember specifics because i haven't booted in a while. I have seen in other places that it is possible to change the resolution via the Terminal, but like earlier stated, i don't really want to go playing about with system files without a clue.

Hi Sam_

Got the issue sorted - It turns out that my nVidia drivers were causing issues. Followed the commands set out by the first responder here:

http://askubuntu.com/questions/37590/nvidia-drivers-not-working-after-upgrade-why-can-i-only-see-terminal

Whilst perhaps not appropriate for this thread, step 4 (sudo dkms remove nvidia) didn't work as the command was not found, however, on the positive side, it wasn't needed.

The drivers rebuilt themselves and i am a very happy bunny.

Thanks!

Sam_ (and-sam) said : #5

Well done and thanks for sharing.