Ubuntu

Video messed up in 12.04

Asked by Bjorn Semanas on 2012-05-13

I recently upgraded to 12.04, and things seemed to be working well. Booting up today, the video configuration was messed up, with text and icons very small (I am running a nettop box to my tv- zotac zbox with nvidia ion graphics). I started messing around with the resolution settings, trying to put them equal to what my guest settings were defaulted at, but this did not resolve the problem, and I ended up with huge icons and horribly slow response times on the screen.

Messing around in the terminal I have manage to get things worse. I tried "unity --reset", updating, re-installing unity, tried updating some nvidia drivers, and managed to progressively worsen things to the point that when I try to boot now, the computer hangs up on "Checking Battery State...ok" and "stopping system v runlevel compatibility", which I can only get out of by going to a terminal and typing "xstart", but now my graphical interface is so messed up that I cant access the guest account, or make any other adjustments.

Is there any hope to sort this out, or will I need to do a clean install? And if I need to do a clean install, how do I make sure that my media files on the internal hard drive are not affected?

Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-14
Last reply:
2012-05-14

The probably only thing you changed are your users's settings. So a reinstall is not needed in any way. If you log in to the Unity2D session you will be able to use the system.

Can you give the output of:

sudo lshw -C display; lsb_release -a; uname -a; dpkg -l | grep nvidia

Thanks

Grzegorz G. (grzesiek1e5) said : #2

If you want to make a clean install, be sure to backup your files from internal drive using LiveCD or LiveUSB.
But try to fix this first :)

Bjorn Semanas (matrixbjj) said : #3

Thanks for replying. I am not able to log into a Unity 2D session; when I boot up the computer hangs on "Checking Battery State...ok" and "stopping system v runlevel compatibility", which I can only get out of by going to a terminal and typing "xstart" after logging in with my user id. Probably ignorance on my part, but I have not been able to figure out how to get into unity 2D when logging in from a terminal and using "Xstart" to get into my graphical interface (which is now very messed up and pretty much unusable).

Here is the output:

From lshw -C display i get:
*-display
    description: VGA compatible controller
    product: GT218 [ION]
    vendorÑ NVIDIA Corporation
    physical id: 0
    bus info: pci@0000:03:00.0
    version: a2
    width: 64 bits
    clock: 33 MHz
    compatibilitiesÑ pm msi pciexpress vga_controller bus_master cap_list rom
    configuration: driver=nvidia latency=0
    resources: irq:18 memory: fd000000-fdffffff memory:d0000000_dfffffff memory:ce:000000-cfffffff ioport:dc00(size=128) memory:fcf80000-fcffffff

from lsb_release -a:

No LSB modules are available
Distributor ID: Ubuntu
Desciption: Ubuntu 12.04 LTS
Release: 12.04
Codename: Precise

from uname -a:

Linux bjorn-desktop 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:52 UTC 2012 i686 i686 i386 GNU/Linux

from dpkg -l grep nvidia
ii nvidia-common 1:0.2.44
    Find obsolete NVIDIA drivers
ii nvidia-current 295.40-Oubuntu1
    NVIDIA binary Xord driver, kernel module and VDPAU library
ii nvidia-settings 295.33-Oubuntu1
    Tool of configuring the NVIDIA graphics driver

Hope I got that right - I have had to manually copy this over to another computer

Thanks again

Bjorn Semanas (matrixbjj) said : #4

This is going from bad to worse. I made a live USB to at least get at my information. However, my computer does not boot to the USB drive automatically. I have tried booting while holding f9, f11 and delete keys on different occasions, but none of them are taking me to BIOS where I can set the boot sequence. No manufacturer's splash screen shows up on the boot, I am just taken straight to the Ubuntu boot on the internal drive, which hangs up as before, and I have to go to a terminal just to shut down.

I am using a wireless keyboard, so I will go to work and see if I can get a wired one from work in case that works any better, but things are not looking good.

Now that I think about it, I dont think the system has ever showed me the manufacture's splash screen on boot-up.

John F Leach (jfleach) said : #5

Perhaps trying F2 or ESC will bring up the BIOS.

Sam_ (and-sam) said : #6

There're still issues with nvidia-current.
https://answers.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+question/194226

After boot try login to virtual console (text mode only): ctrl+alt+f1
Purge nvidia-current, clean package cache, update, reboot.
apt-get purge nvidia-current
apt-get autoremove
apt-get clean
apt-get update
apt-get upgrade
apt-get -f install
reboot

Verify there is no leftover of nvidia xorg.conf in /etc/X11.

To get the greeter from where to select sessions run lightdm manually.
sudo service start lightdm

btw. cmd to run Xserver is: startx
http://www.x.org/wiki/FAQ

Bjorn Semanas (matrixbjj) said : #7

Sam - this is the most advance I have had so far - I finally have access to something that looks like my desktop.

Running the update and upgrade it seemed like the system failed to get a lot of packages, but with the reboot and a terminal, using startx I was able to get a functioning desktop.

I am still not with a fully functioning system, but this is a lot of advance - thanks.

Some questions:
1) in /etc/x11 I have xorg.conf, xorg.conf.backup and xorg.conf.failsafe. What did you mean by verify there is no leftover of nvidia? I was able to copy the files to another folder, but cannot delete or rename them.

2) I tried going back to the terminal (alt-ctrl-f1) and killing the xserver (ctrl-c) to get the command line prompt again. When I typed:

sudo service start lightdm

I got:

start: unrecognized service

Thanks again for the help, and anything more you can suggest to get me further on my way is much appreciated.

Thanks

Bjorn Semanas (matrixbjj) said : #8

just an update on the above - my internet connection had conked out. Got it up and running, and re-ran the list of commands you gave me from a terminal. Looks like everything loaded this time.

I still have to use a terminal and startx to get into the desktop, and I am still getting the "unrecognized service" message when I try to start lightdm.

Bjorn Semanas (matrixbjj) said : #9

One more update - I figured out how to get into BIOS. I needed to repeatedly hit (not press and hold) the delete key during startup. Internet research shows that this is a pretty common problem when outputting video to the HDMI - the video output doesn't kick in until after the bios option splash page has already passed, so you never actually see it...but it is there and will pick up on the key press.

So, I still don't have a functioning system. Hopefully someone can help me get further along with this, but if not, at least I have the possibiity to recover my files and do a clean install.

Bjorn Semanas (matrixbjj) said : #10

Thanks for replying. I am not able to log into a Unity 2D session; when I boot up the computer hangs on "Checking Battery State...ok" and "stopping system v runlevel compatibility", which I can only get out of by going to a terminal and typing "xstart" after logging in with my user id. Probably ignorance on my part, but I have not been able to figure out how to get into unity 2D when logging in from a terminal and using "Xstart" to get into my graphical interface (which is now very messed up and pretty much unusable).

Here is the output:

From lshw -C display i get:
*-display
    description: VGA compatible controller
    product: GT218 [ION]
    vendorÑ NVIDIA Corporation
    physical id: 0
    bus info: pci@0000:03:00.0
    version: a2
    width: 64 bits
    clock: 33 MHz
    compatibilitiesÑ pm msi pciexpress vga_controller bus_master cap_list rom
    configuration: driver=nvidia latency=0
    resources: irq:18 memory: fd000000-fdffffff memory:d0000000_dfffffff memory:ce:000000-cfffffff ioport:dc00(size=128) memory:fcf80000-fcffffff

from lsb_release -a:

No LSB modules are available
Distributor ID: Ubuntu
Desciption: Ubuntu 12.04 LTS
Release: 12.04
Codename: Precise

from uname -a:

Linux bjorn-desktop 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:52 UTC 2012 i686 i686 i386 GNU/Linux

from dpkg -l grep nvidia
ii nvidia-common 1:0.2.44
    Find obsolete NVIDIA drivers
ii nvidia-current 295.40-Oubuntu1
    NVIDIA binary Xord driver, kernel module and VDPAU library
ii nvidia-settings 295.33-Oubuntu1
    Tool of configuring the NVIDIA graphics driver

Hope I got that right - I have had to manually copy this over to another computer

Thanks again

Bjorn Semanas (matrixbjj) said : #11

please ignore the above - accidental double post.

Sam_ (and-sam) said : #12

> start: unrecognized service

There're always alternatives as other upstart cmds.
sudo start lightdm
sudo restart lightdm
sudo stop lightdm
sudo dpkg-reconfigure lightdm

> 1) in /etc/x11 I have xorg.conf, xorg.conf.backup and xorg.conf.failsafe.

The .failsafe is just a template.
The xorg.conf is the one which is currently 'on', the xorg.conf.backup obviously is the backup file of xorg.conf.
System relevant actions are possible with temporarily elevated permissions via 'sudo'.
e.g.
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.broken

in reverse (make .broken the origin again):
sudo mv /etc/X11/xorg.conf.broken /etc/X11/xorg.conf

Without any GUI you can open, review and edit any textfile anywhere in a terminal or virtual console by
e.g.
sudo nano /etc/X11/xorg.conf
https://help.ubuntu.com/community/Nano

## btw. in /etc/X11/ is also a file called:
default-display-manager

It should have this content (as first line):
/usr/sbin/lightdm

To only review the content:
cat /etc/X11/default-display-manager

The output of:
sudo lshw -C display

or as alternative:
lspci -nnk | grep -i VGA -A2

will tell which driver is in use, nvidia or nouveau.

If you're confident to roll back then activate the nvidia driver again in
system-settings -> additional drivers

or install nvidia-current manually, make sure the system is updated, has no pending or broken packages.
After installation it may need this to activate the driver:
sudo nvidia-xconfig
sudo reboot

When there is trouble verify there're no two xorg.conf written by nvidia, in case rename the older one.
Anyway you can't do something wrong really, any step can be reverted it just needs testing which driver and config work and which not.
When the driver is the culprit a new installation won't help either.

https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

Can you help with this problem?

Provide an answer of your own, or ask Bjorn Semanas for more information if necessary.

To post a message you must log in.