Screen resolution stuck at 640x480, flickering madly and continuously turns off and on

Asked by Hyung-joon Ahn on 2012-04-10

I've been using Ubuntu since 2006 and all this time I've never faced a problem I couldn't solve by searching the internet until now. I've been at this for over a week and still can't find a solution.

My computer is an Intel i5, 4GB RAM, Nvidia GT520. My monitor is an Achieva Shimian QH270-IPSB capable of 2560x1440@60hz through DVI-D. I usually dual boot between Windows and Ubuntu 64bit Desktop. The monitor works just fine on Windows at 2560x1440.

The live CD works fine at native resolution (2560x1440@60hz) but after a clean install the screen resolution is stuck at 640x480. The screen flickers madly and the monitor goes black as if going into sleep mode and then comes back again constantly. Even with the screen off, keyboard and mouse inputs are registered.

I can't get higher resolution from nvidia-settings.

I can switch to tty which seems to be working at native resolution.

I've tried directly installing NVidia drivers downloaded from Nvidia as well as from https://launchpad.net/~ubuntu-x-swat/+archive/x-updates.

I tried forcing the native resolution by adding a modeline into xorg.conf which resulted in total black screen with tty as the only option. xrandr complains about failed to get size of gamma for output default.

I tried switching to linux mint lisa but got the same deal after installing the proprietary drivers.

It gets even weirder after switching to nouveau. The screen gets split into about 16 identical screens (also flickering like crazy) and at that point even tty is unusable because tty pops up in one of the screens.

I don't need any fancy OpenGL window compositing magic but I do need a useable Ubuntu installation for work, hence anything on the level of the live CD would make me a very happy person. I think I've tried everything I've found on the net. Is there anything else I could try?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-27
Last reply:
2012-04-27

Can you give the output of:

sudo lshw -C display; uname -a; lsb_release -a

Thanks.

Sam_ (and-sam) said : #2

If LiveCD displays fine and installation afterwards is corrupted to 640x480 consider to report a bug.
In case diff of xorg.conf generated by nivdia from LiveCD and installation gives a hint.

Maybe try HDMI connect instead of DVI-D.
Verify Xorg.0.log if it finds EDID for DVI-D.
Example entry from my log file.
EDID for output HDMI-0

Maybe this hint helps, add highest mode, change back to lower res hoping that display settings complain.
https://wiki.ubuntu.com/X/Config/Resolution#Setting_resolution_changes_in_xorg.conf.2BIBQ-resolution_lower_than_expected

Hyung-joon Ahn (bigriot) said : #3

@actionparsnip Thanks for sparing me your time. I get the following output:

 *-display
       description: VGA compatible controller
       product: GF119 [Geforce GT 520]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33Mhz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:f6000000-f6ffffff memory:e8000000-effffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f70000000-f707ffff
Linux msisle-ubuntu 3.2.0-20-generic #33-ubuntu SMP Tue Mar 27 16:42:26 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu precise (development branch)
Release: 12.04
Codename: precise

ok and the output of:

dpkg -l | grep nvidia

Thanks

Hyung-joon Ahn (bigriot) said : #5

@actionparsnip

nvidia-common 1:0.2.42 Find obsolete NVIDIA drivers
nvidia-current 295.33-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library
nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver

Thanks again.

Hyung-joon Ahn (bigriot) said : #6

@actionparsnip

nvidia-common 1:0.2.42 Find obsolete NVIDIA drivers
nvidia-current 295.33-0ubuntu1 NVIDIA binary Xorg driver, kernel module and VDPAU library
nvidia-settings 295.33-0ubuntu1 Tool of configuring the NVIDIA graphics driver

Thanks again.

Try:

sudo nvidia-xconfig

and reboot

Hyung-joon Ahn (bigriot) said : #8

@Sam_

Unfortunately my monitor only supports DVI-D :(

I tried the workaround at your link but haven't had much luck either.

I've tried switching the VGA card to a geforce 9600GT and when that didn't work I tried a smaller dvi-i monitor (with a much lower res) but that didn't help either.

According to Xorg.0.log the EDID is invalid due to checksum error. I guess this is the root of the problem. Would there be any way to force an EDID?

The log keeps mentioning nvidia-auto-select. Which I'm guessing is a failsafe default mode due to the monitor not being recognized correctly.

Hyung-joon Ahn (bigriot) said : #9

@actionparsnip

I've tried that a couple of times but no gold.

@Sam_

I'm a bit reluctant to report this as a bug because I haven't seen anyone else having this issue (at least not on the forums) and thought I should make sure there's nothing wrong with my hardware before crying wolf.

Sam_ (and-sam) said : #10

Try:
sudo get-edid

For workarounds and hints please note bug report linked on top.
According to a comment there
If the title error matches exactly yours try the workaround of #21
to disable hot-plug detection:
~$ echo 0 > /sys/module/drm_kms_helper/parameters/poll

Anyway with the right keywords one can find lots of 'edid checksum errors' for variant reasons and graphics cards.
Apparently 12.04 in particular depends which hardware it is running on. Hardware evolves faster, some users have a brand new or rather antique hw. In testing forums some users have trouble to get 12.04 running at all, others have no issue at all. Very very variable.

> reluctant to report this as a bug

Bug indication was given with different outcomes of live-cd vs. installation.
Why would it be recognized fine on LiveCD?
Can even be further excluded by testing another distro.

> Unfortunately my monitor only supports DVI-D

Yep, in the meantime I've read reviews. Imho it's kind of optimistic to buy a monitor with only one option to connect.

Sean McCabe (stkmccabe) said : #11

I just struggled through the same thing with an Achieva Shimian QH270-Lite on an Nvidia Quadro FX 380 (Dell Precision T1500). Tons of EDID errors on the tty, the card only willing to do 640x480, even while pushing 1920x1080 on the other dvi port.

What might be of interest to you is that I'm not on Ubuntu. This happened to me on Fedora 16, kernel 3.3.2. That seems like a driver problem then, right?

> Imho it's kind of optimistic to buy a monitor with only one option to connect.
When it's a 2560x1440 panel for ~$350, I'm willing to make some compromises.

My workaround ended up being to swap in an ancient ATI Radeon X1600 that was lying around, and running it on open source ATI drivers--had to reinstall most of Xorg to get rid of all the leftover libs that the Nvidia 295.40 and the Catalyst drivers left lying around.

Hyung-joon Ahn (bigriot) said : #12

@stkmccabe

That's disconcerting to hear :(

I still haven't been able to work this out but I do agree that the drivers seem to be at fault. In recovery mode (i.e no nvidia drivers loaded) the EDID seems to be recognized just fine but all hell breaks loose when switched to normal mode.

I don't have an old ATI card handy at the moment but am willing to fork some cash for a new one. Do you think your workaround could work with recent ATI cards ?

Sam_ (and-sam) said : #13

Regarding support of *recent* ati cards you'd like to query hd databases. As in #10 mentioned brand new or antique are risky.
http://www.ubuntu.com/certification/catalog/
http://friendly.ubuntu.com/
http://wiki.cchtml.com/index.php/Hardware

And in case fglrx-installer bug reports.
https://bugs.launchpad.net/ubuntu/+source/fglrx-installer

Sean McCabe (stkmccabe) said : #14

> Do you think your workaround could work with recent ATI cards ?
i confirmed it with a HD 5770. (But sadly, the card belongs to another machine.)
on the X1600, there's a strange limitation that if i spanned the 1920x1080 side-by-side with the Shimian, i get artifacts and the system hangs. stacking the displays vertically worked. maybe it has something to do with the virtual desktop width?
on the HD 5770, everything worked fine (ati open source drivers).

i also tried:
FX 380 w/ Ubuntu 11 64-bit livecd: works using nouveau, unity doesn't even try to activate
FX 380 w/ Ubunut 12 64-bit livecd: works until you click "Try Ubuntu", then X restarts, unity tries to activate, artifacts, hangs

my current understanding is that:
nouveau hates the shimian under 3d, but could probably do gnome 2 fine
nvidia hates the shimian in general
ati (open source) works
catalyst/fglrx hates life in general (or maybe just gnome 3)

good luck!

Can you help with this problem?

Provide an answer of your own, or ask Hyung-joon Ahn for more information if necessary.

To post a message you must log in.