Ubuntu

Nvidia Geforce 8400gs Overscan Issue

Asked by Matthew on 2012-03-18

I have a problem with the overscan on my Nvidia Geforce 8400GS. I did some research and I noticed other people have the same problems. It only occurs when I install the restricted drivers from Nvidia. Is there a way I can fix this in Ubuntu 11.10/12.04?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Solved by:
Matthew
Solved:
2012-03-24
Last query:
2012-03-24
Last reply:
2012-03-19

If you run:

sudo nvidia-xconfig; gksudo nvidia-settings

You can set the res and refresh rate to something and click 'save to x config file', you can then run:

gksudo gedit /etc/X11/xorg.conf

And set the resolution to what you should use with your screen. May help

Matthew (ruinairas1992) said : #2

No matter what resolution is set the overscan makes the image to big. I need to figure out how to disable the overscan all together. Normally you use "PC Mode" on HD Tv's, but for some reason that option is greyed out. This is a 42" Phillips HD TV

Matthew (ruinairas1992) said : #3

 nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 295.20 (buildd@vernadsky) Sat Feb 18 09:50:08 UTC 2012

Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "PHILIPS"
    HorizSync 65.0 - 69.0
    VertRefresh 57.0 - 63.0
    Option "DPMS"
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 8400GS"
    BusID "PCI:2:0:0"
EndSection

Section "Screen"

# Removed Option "metamodes" "1280x960 +0+0"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "1280x960 +0+0; nvidia-auto-select +0+0"
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

Does the screen have an OSD you can play with. It may need tweaking

Matthew (ruinairas1992) said : #5

I don't think so. It's very limited to what I can do. In Windows 7 if I switch the graphics to 720p it works correctly. How do I do this with Ubuntu?

Matthew (ruinairas1992) said : #6

Fixed by using the overscan slider on the Nivida-Settings tool. Hope this helps anyone else who might have this issue. It's easy to overlook it so please check closely. :D