Nvidia Go 7400 & Compiz issues on Ubuntu 11.04

Asked by Gregory Brown on 2011-04-12

I`ve upgraded to Ubuntu 11.04. The process went great until I restarted the computer and tried to login.
After putting in my password, the system would draw the Unity (or Ubuntu Classic) screens and apparently freeze.
After fiddling around, I noticed that using Ubuntu Classic (no effects) I could get into the system and use it normally, leading me to think that the problem was with Compiz and Nvidia drivers.
I re-installed the Nvidia drivers, updated everything I could and sill, my screen freezes when using compiz.

I am not sure if it`s a specific problem with my GeoForce Go 7400 or with a whole series of nVidia boards... just thought I`d let you all know about it and how you can work-around to at least use your system.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Last query:
2011-04-12
Last reply:
2011-05-06

As you probably know, Ubuntu 11.04 is still in beta and bugs, including serious bugs, are still to be expected. If you want to run a stable system, you should use Ubuntu 10.10 or Ubuntu 10.04, until Ubuntu 11.04 is formally released. However, if you want to test Ubuntu 11.04 and report bugs as you find them, then your assistance is most appreciated!

Does the problem persist when you switch from the proprietary nvidia drivers to nouveau?

If not, then this is probably a bug in the proprietary nvidia drivers. So if that is the case, please (temporarily) switch back to the proprietary nvidia drivers and report a bug in them by running "ubuntu-bug nvidia-current". If it persists with the nouveau drivers, then please report it as a bug in compiz by running "ubuntu-bug compiz". Either way, make sure to include the information you've posted here as well as any new relevant information in your bug report. Before reporting any bugs, please make sure to read https://help.ubuntu.com/community/ReportingBugs carefully. After reporting your bug, please link it and this question to each other by using the "Link existing bug" link near the top of this question page. While it is a good idea to do that, your bug report should itself be complete and self-contained--the Ubuntu developers should not need to refer to this question in order to fully understand and appreciate your bug.

John Merrill (delirus) said : #2

This is definitely related to the proprietary Nvidia driver version that is default in 11.04 beta.
I think this problem was associated with either nvidia-drivers-270.41.03 or nvidia-drivers-270.18 (I don't remember which version was default in Ubuntu 11.04 beta2 when I experienced this bug)
The problem went away when I manually installed nvidia-drivers-260.19.44, which was the version recommended by nvidia at the time.

Since that time (a week ago), Nvidia changed its recommendation to 270.41.06, but I have not had a chance to test this version yet.

matroska (matroska) said : #3

I have tried to install 260.19.44 as well but Ubuntu doesn't start at all. The error message is something related to ABI version!?!?

Can you help with this problem?

Provide an answer of your own, or ask Gregory Brown for more information if necessary.

To post a message you must log in.