10.10 upgrade nvidia module not found

Asked by Winton Roseland on 2011-01-23

My Ubuntu system upgraded from 10.04 to 10.10 and I get the following error and only have terminal access. FATAL: Module nvidia not found (EE) NVIDIA(0): Failed to load the NVIDIA Kernel module! (EE) NVIDIA(0) *** Aborting ***. This message is in the x-log and on the screen when I do a startx. Can anyone help me fix this? My system has been without a GUI for over a week now. I have asked this question on the inst/upgrade forum also. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nvidia-graphics-drivers Edit question
Assignee:
No assignee Edit question
Solved by:
Winton Roseland
Solved:
2011-01-28
Last query:
2011-01-28
Last reply:
2011-01-24

Hi Winton Roseland,

First fix the lack of GUI using the nvidia open-source modules. To achieve that copy and paste the following command in the shell (get a shell with ctrl+alt+F1):

sudo sed -i 's/nvidia/nv/' /etc/X11/xorg.conf

after that either reboot or issue the following command:

sudo /etc/init.d/gdm restart

After that you'll get your GUI back.

Now if you want to use the closed nvidia dirvers working back go to "system -> Administration -> additional drivers" (I've translated the following sequence from spanish so the names may vary). And follow its instructions to re-enable nvidia drivers.

HTH

--
hmontoliu <at> ubuntu.com
http://hmontoliu.blogspot.com

Winton Roseland (wroseland) said : #2

That got a GUI back but the screen his squashed side to side and extends off the bottom of my monitor so I cannot access programs. Where can I set a better display size? Thanks

Using the auto-setup of your monitor

"Winton Roseland" <email address hidden> escribió:

>Question #142545 on nvidia-graphics-drivers in ubuntu changed:
>https://answers.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+question/142545
>
> Status: Answered => Open
>
>Winton Roseland is still having a problem:
>That got a GUI back but the screen his squashed side to side and
>extends
>off the bottom of my monitor so I cannot access programs. Where can I
>set a better display size? Thanks
>
>--
>You received this question notification because you are a direct
>subscriber of the question.

--
Enviado desde mi teléfono Android con K-9 Mail. Disculpa mi brevedad

Winton Roseland (wroseland) said : #4

That does not work. There must be a config file somewhere that controls the display settings. Does anybody know its name?

Winton Roseland (wroseland) said : #5

Thanks for the assistance.
1) I modified xorg.conf to use vesa driver, set the sync and refresh rates to match my monitor, added a bunch of display settings for various depths. This corrected my GUI. At this point the auto-setup worked to correct the display that was slightly off center at this point.
 2) I am not sure why there are so many problems with nvidia drivers and Debian distro. It is just software! It looks as if this stuff is never tested. I have had difficulties with my nvidia components several times after an upgrade. I am sure that there are many ubuntu users who would test install to see what happens. I would (as long as I have a good way to recover when it fails). There seems to be a lot of problems.
 3) Now when I go to the software update application, it tells me that I have done a partial upgrade. The message is that an upgrade from 'maverick' to 'lucid' is not supported by this tool.