I need a previous version of this package

Asked by Dirk H on 2020-03-14

How do I select or build a previous version the packages on this ppa? I am interested specifically in selecting nvidia-graphics-drivers-440 440.59-0ubuntu0.18.04.1. Any help would be appreciated. Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nvidia-graphics-drivers-440 Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2020-03-14
Last query:
2020-03-14
Last reply:
2020-03-14
Manfred Hampl (m-hampl) said : #1

Which PPA (=Personal Package Archive) are you talking about?
The package nvidia-graphics-drivers-440 version 440.59-0ubuntu0.18.04.1 is available in the standard Ubuntu repositories for Ubuntu bionic. I do not see any need for building these packages yourself.

see
https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-440
https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-440/440.59-0ubuntu0.18.04.1

For diagnostic purposes, what is the output of the commands (to be executed in a terminal window):

uname -a
lsb_release -crid
apt-cache policy nvidia-driver-440

Dirk H (somename+) said : #2

~$ uname -a
Linux crashoverride 4.15.0-88-generic #88-Ubuntu SMP Tue Feb 11 20:11:34 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

~$ lsb_release -crid
Distributor ID: neon
Description: KDE neon User Edition 5.18
Release: 18.04
Codename: bionic

~$ apt-cache policy nvidia-driver-440
nvidia-driver-440:
  Installed: 440.33.01-0ubuntu1
  Candidate: 440.64.00-0ubuntu1
  Version table:
     440.64.00-0ubuntu1 500
        500 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64 Packages
     440.64-0ubuntu0~0.18.04.2 500
        500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main amd64 Packages
 *** 440.33.01-0ubuntu1 500
        500 http://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64 Packages
        100 /var/lib/dpkg/status

If you are unaware neon is just Ubuntu 18.04 with updated KDE software. I'm not sure how I can use these packages since I do not have it in my policy anymore.

Manfred Hampl (m-hampl) said : #3

They are in the multiverse repository. It seems that you do not have that one enabled, but a PPA and a foreign repository instead.

see https://help.ubuntu.com/community/Repositories/Kubuntu

Dirk H (somename+) said : #4

I'm very confused because I have universe enabled and it seems nvidia-driver-430 provides 440.59 like I want but 440 does not

~$ apt-cache policy nvidia-driver-430
nvidia-driver-430:
  Installed: (none)
  Candidate: 440.59-0ubuntu0.18.04.1
  Version table:
     440.59-0ubuntu0.18.04.1 500
        500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic/main amd64 Packages
     430.50-0ubuntu0.18.04.2 500
        500 http://us.archive.ubuntu.com/ubuntu bionic-updates/restricted amd64

Maybe this is off-topic but do you have any ideas of how I should fix my sources?

Best Manfred Hampl (m-hampl) said : #5

Oops, sorry, I missed to notice that this version is only in "bionic-proposed multiverse".

The version that you are looking for seems to be in https://launchpad.net/~albertomilone/+archive/ubuntu/kernel-sru-testing

About the strange naming difference 430/440 you have to askt the provider of that PPA.

Why do you need exactly that version?

Dirk H (somename+) said : #6

It was the last working version for RuneLite GPU plugin. Thanks for the help it is working now.

Dirk H (somename+) said : #7

Thanks Manfred Hampl, that solved my question.