Installing i386 version basically impossible in xenial

Asked by Dario on 2017-07-29

In my understanding, on my 64-bit xenial it's not possible to install nvidia-375:i386 (for steam and wine) because it depends on xserver-xorg-core:i386, which in turn depends (and there might be others) on keyboard-configuration:i386, which sadly does not exist because it's actually keyboard-configuration:all.

Is there any hope or should I simply switch back to the proprietary installer I just escaped from?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu nvidia-graphics-drivers-375 Edit question
Assignee:
No assignee Edit question
Solved by:
Dario
Solved:
2017-07-30
Last query:
2017-07-30
Last reply:
2017-07-30
Manfred Hampl (m-hampl) said : #1

What output do you get for the commands

uname -a
lsb_release -crid
apt-get --simulate install nvidia-375:i386

Dario (dcorti) said : #2

Here it is. If you think this is Mint related I can install a pure Ubuntu in no time and test again. Btw I checked that I don't have held packages messing around.

*** uname -a
Linux ivylin 4.4.0-87-generic #110-Ubuntu SMP Tue Jul 18 12:55:35 UTC 2017 x86_64 x86_64 x86_64
GNU/Linux

*** lst_release -crid
Distributor ID: LinuxMint
Description: Linux Mint 18.2 Sonya
Release: 18.2
Codename: sonya

*** apt-get --simulate install nvidia-375:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-375:i386 : Depends: make:i386
                   Depends: xorg-video-abi-11:i386 but it is not installable or
                            xorg-video-abi-12:i386 but it is not installable or
                            xorg-video-abi-13:i386 but it is not installable or
                            xorg-video-abi-14:i386 but it is not installable or
                            xorg-video-abi-15:i386 but it is not installable or
                            xorg-video-abi-18:i386 but it is not installable or
                            xorg-video-abi-19:i386 but it is not installable or
                            xorg-video-abi-20:i386 or
                            xorg-video-abi-23:i386
                   Depends: xserver-xorg-core:i386
                   Recommends: nvidia-settings:i386 (>= 331.20) but it is not going to be installed
                   Recommends: nvidia-prime:i386 (>= 0.5) but it is not going to be installed or
                               bumblebee:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages

*** apt-get --simulate install xserver-xorg-core:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-core:i386 : Depends: keyboard-configuration:i386 but it is not installable
                          Recommends: libpam-systemd:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

*** apt-get --simulate install keyboard-configuration:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package keyboard-configuration:i386 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'keyboard-configuration:i386' has no installation candidate

*** dpkg -l keyboard-configuration
ii keyboard-configuration 1.108ubuntu15.3 all

Manfred Hampl (m-hampl) said : #3

This is support for Ubuntu, and not for any other "Ubuntu-based" operating system.

For questions about Linux Mint please see the support pages for that operating system
https://linuxmint.com/contactus.php and https://forums.linuxmint.com/

Dario (dcorti) said : #4

I completely understand you point, so I installed a clean zesty, update everything and tried again. Different packages but same issue.
This time screen-resolution-extra is not installable as a dependency for an i386 package because its arch is all. I think this has something to do with M-A:foreign but I'm not sure on which packages. I know this is circumvented by installing the driver from nvidia.com but I don't like the way they tend to mess with system files and configs... a clean install from the official repo would be preferable.

root@ivyubuntu:~# uname -a
Linux ivyubuntu 4.10.0-28-generic #32-Ubuntu SMP Fri Jun 30 05:32:18 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

root@ivyubuntu:~# lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 17.04
Release: 17.04
Codename: zesty

root@ivyubuntu:~# apt-get --simulate install nvidia-375:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-375:i386 : Depends: make:i386
                   Recommends: nvidia-settings:i386 (>= 331.20) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

root@ivyubuntu:~# apt-get --simulate install nvidia-settings:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-settings:i386 : Depends: screen-resolution-extra:i386 (>= 0.12) but it is not installable
E: Unable to correct problems, you have held broken packages.

Manfred Hampl (m-hampl) said : #5

What is the output of

apt-cache policy screen-resolution-extra screen-resolution-extra:i386 nvidia-settings:i386
apt-get --simulate --no-install-recommends install nvidia-375:i386

Dario (dcorti) said : #6

root@ivyubuntu:~# apt-cache policy screen-resolution-extra screen-resolution-extra:i386 nvidia-settings:i386
screen-resolution-extra:
  Installed: 0.17.1
  Candidate: 0.17.1
  Version table:
 *** 0.17.1 500
        500 http://it.archive.ubuntu.com/ubuntu zesty/main amd64 Packages
        500 http://it.archive.ubuntu.com/ubuntu zesty/main i386 Packages
        100 /var/lib/dpkg/status
screen-resolution-extra:i386:
  Installed: (none)
  Candidate: (none)
  Version table:
nvidia-settings:i386:
  Installed: (none)
  Candidate: 367.35-0ubuntu1
  Version table:
     367.35-0ubuntu1 500
        500 http://it.archive.ubuntu.com/ubuntu zesty/main i386 Packages

root@ivyubuntu:~# apt-get --simulate --no-install-recommends install nvidia-375:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-375:i386 : Depends: make:i386
                   Depends: acpid:i386 but it is not going to be installed
                   Depends: xorg-video-abi-11:i386 but it is not installable or
                            xorg-video-abi-12:i386 but it is not installable or
                            xorg-video-abi-13:i386 but it is not installable or
                            xorg-video-abi-14:i386 but it is not installable or
                            xorg-video-abi-15:i386 but it is not installable or
                            xorg-video-abi-18:i386 but it is not installable or
                            xorg-video-abi-19:i386 but it is not installable or
                            xorg-video-abi-20:i386 but it is not installable or
                            xorg-video-abi-23:i386
                   Depends: xserver-xorg-core:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

So we are basically where we were with Mint. At this point, if I try to install xserver-xorg-core:i386 it sort of goes through but by removing among the others ubuntu-desktop, xorg, xserver-xorg etc, which if of course not what I was hoping for.

root@ivyubuntu:~# apt-get --simulate install xserver-xorg-core:i386
[...]
The following packages will be REMOVED:
  ubuntu-desktop xorg xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-libinput xserver-xorg-input-synaptics
  xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev
  xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-radeon xserver-xorg-video-vesa
  xserver-xorg-video-vmware

Also acpid:i386 would remove acpid and consequently nvidia-375:

root@ivyubuntu:~# apt-get --simulate install acpid:i386
[...]
The following packages will be REMOVED:
  acpi-support acpid libcuda1-375 nvidia-375 nvidia-opencl-icd-375

Manfred Hampl (m-hampl) said : #7

It seems strange to me that installing xserver-xorg-core:i386 uninstalls xserver-xorg-core

apt-get --simulate install xserver-xorg-core xserver-xorg-core:i386

Are you sure that you need nvidia-375:i386 for steam and wine?

Distributor ID: LinuxMint
Description: Linux Mint 18.2 Sonya
Release: 18.2
Codename: sonya

Mint is not supported by the Ubuntu community in any way. It's support community is entirely separate from Ubuntu's. None of the "Ubuntu based" distributions are supported here.

I suggest you post on the Mint forum here:
https://forums.linuxmint.com

This is where your distribution is supported.

Manfred Hampl (m-hampl) said : #10

@actionparsnip: look at comment #4

lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 17.04
Release: 17.04
Codename: zesty

Dario (dcorti) said : #11

Ok first of all sorry, I probably was trying to do something that simply isn't meant to be done and/or is not needed. My actual problem (with Mint, not with the tests on Ubuntu) was that the nvidia installer probably left something broken around. I removed a a mesa version of libGL.so and everything worked with the packages I already had, because they already include the 32 bit libraries I need. Sorry again for wasting your time.