Why does a new nvidia driver package require making the existing driver package transitional?

Asked by Mark Foster on 2017-05-02

It seems the way the driver package updates are released it is making our users suffer grief when the new version is not working right yet the version they were running (which is now 'transitional') prevents a rollback.
I've seen this with both the nvidia-367 and nvidia-361 packages now. Please stop it doing it that way.
Please just make an nvidia package virtual that depends on / is satisfied by any of the nvidia-* (361, 367, 375) etc.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nvidia-graphics-drivers-375 Edit question
Assignee:
No assignee Edit question
Last query:
2017-05-02
Last reply:
2017-05-03

I suggest you report a bug

Can you help with this problem?

Provide an answer of your own, or ask Mark Foster for more information if necessary.

To post a message you must log in.