How can I undo a NTFS-3G upgrade?

Asked by Jens on 2017-07-08

Hello,

yesterday I upgraded NTFS-3G with the latest stable version from Tuxera (2017.3.23) on my Kubuntu 14 LTS
– Yes I know it is outdated, but I got a special multimedia program I need which caused installation problems on xUbuntu 16. So no choice for me until this issue is solved. –

Unfortunately now I cannot mount 2 of my NTFS partitions due to $MFT mirror mismatch errors. But the point is, that Windows 7's CHKDSK does not recognize any errors so there is nothing to repair and I do not have enough free space to save the data somewhere else to reformat those 2 partitions. Anyhow, even if I could, this does not necessarily mean, it would solve this bug.

My thought was now to revert NTFS-3G to the original Kubuntu version (2013.1.13AR.1), because this previous version didn't refuse to mount those 2 partitions. But I couldn't find any hint how to do that. So is there a chance to downgrade/revert/undo this installation? Or do I have to purge NTFS-3G completely and reinstall it afterwards? And if so, what do I have to observe for not to loose any other data or settings or messing up my system in any other way?

Thank you in advance,

Jens

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ntfs-3g Edit question
Assignee:
No assignee Edit question
Solved by:
Jens
Solved:
Last query:
Last reply:

I assume you mean Kubuntu 14. 04.

"Ubuntu 14" doesn't exist.

How did you upgrade the software please?

Jens (i-m-jens-3) said : #2

Yes, the LTS edition. To be precisely 14.04.1 (kernel 3.16.0-77, KDE 4.13.3)

I installed it with the advice by Tuxera (http://www.tuxera.com/community/open-source-ntfs-3g/):

unpack the archive

$ ./configure
$ make
$ sudo make install

that's it.

Could you not get a Dropbox free account, or similar, and upload to that. Or. Grab a 1Tb USB drive (which are cheap).

What is the output of:

dpkg -l | grep -i ntfs

Thanks

Jens (i-m-jens-3) said : #4

Thanks for the storage tip. But last time I uploaded 50 GB (@768 kB/s ADSL) it took a week or so and this time I need at least 128 GB and unfortunately this and next months budgets are already planned.

dpkg output:

ii ntfs-3g 1:2013.1.13AR.1-2ubuntu2 amd64 read/write NTFS driver for FUSE
ii ntfs-config 1.0.1-10 amd64 Enable/disable write support for any NTFS devices

Hmm! Funny the version part!

Here is what ntfs-3g reports:

ntfs-3g 2017.3.23 integrated FUSE 27 - Third Generation NTFS Driver
                Configuration type 1, XATTRS are on, POSIX ACLS are off

Could it be that there is a version incompatibility or some concurrent parts or something like that which may cause my problem?

Try:

sudo apt-get --reinstall install ntfs-3g ntfs-config

This will reinstall the default Canonical package and files.

Manfred Hampl (m-hampl) said : #6

You should verify whether Ubuntu and Tuxera have installed the ntfs-3g programs in the same directory, or in different ones.
The Ubuntu version is /bin/ntfs-3g
What output do you get for the command
which ntfs-3g
?

Jens (i-m-jens-3) said : #7

It is "/bin/ntf-3g".

I think, I'll try your command.

Thank you for this reinstall switch! I didn't know that. ¦-'

So now, it seems so have done well.

And here we go again! The partitions are back online! THANK YOU! THANK YOU! THANK YOU! :D

Well, GParted still reports both partitions with the same error, but at least it was never a problem and regular CHKDSK's & S.M.A.R.T. never reported any faults. So when I can afford to get me another HDD I will have to reformat them.

I will save this command in my NTFS-3G download folder so I will never forget it again. ;)

THANK YOU! :))