[Lucid] Only root can unmount

Asked by Maci on 2010-05-01

Hi!

 I've just upgraded my system from karmic to lucid. It's an amazing system, however I'm experiencing a problem, when I trying to unmount ntfs partitions.

The environment: Latest lucid packages:
xxxx:~$ sudo dpkg -l ntfs*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Név Verzió Leírás
+++-==============-==============-============================================
ii ntfs-3g 1:2010.3.6-1ubuntu1 read-write NTFS driver for FUSE
ii ntfs-config 1.0.1-3ubuntu5 Enable/disable write support for any NTFS devices
un ntfsdoc <nincs> (nincs leírás)
ii ntfsprogs 2.0.0-1ubuntu4 tools for doing neat things in NTFS partitions from Linux

NTFS-config settings: Every option enabled to every ntfs partition.

And the error message from unmount:
Error unmounting: umount exited with exit code 1: helper failed with:
umount: only root can unmount UUID=42D0D290D0D28A15 from /media/work

The owner and the group for the /media/work is the root, instead of my username and group.

How can I solve this problem without sudo all of the time, when I would like to remove a device with NTFS partition on it?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ntfs-3g Edit question
Assignee:
No assignee Edit question
Solved by:
Thomas Krüger
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

nautilus uses polkit and will allow you to unmount/eject ntfs without sudo. if you use server then you can add the mount command to the commands not needing a password for sudo (if you mess up the sudoers file you will become stuck and need the livecd to dig out with)

Revision history for this message
Best Thomas Krüger (thkrueger) said :
#2

To mount the partition as a normal user it has to be listed in /etc/fstab with the user or users option.
See "man mount" and man "man ntfs-3g" for datails!

Revision history for this message
Maci (gergo-nemeth) said :
#3

Thanks Thomas Krüger, that solved my question.