can't launch chrome

Asked by rem on 2017-09-07

I tried adding Java plugin to chrome on Ubuntu 15.10 and after failing that could no longer get chrome at all. When trying to launch from the command line I am told NSS is wrong:

billy@clifton:~$ google-chrome-stable
[13796:13832:0907/181828.997205:FATAL:nss_util.cc(632)] NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.
Aborted (core dumped)
billy@clifton:~$

I'm lost.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nss Edit question
Assignee:
No assignee Edit question
Last query:
2017-09-08
Last reply:
2017-09-11
Manfred Hampl (m-hampl) said : #1

Please see https://wiki.ubuntu.com/Releases
Ubuntu 15.10 is not supported any more (already since July 2016).
You have to upgrade to a supported Ubuntu release. I suggest Ubuntu 16.04 LTS with support until the year 2021.

rem (patterson) said : #2

I did that with another machine last year and found that older PHP programs could no longer run, and my development work was forced off the machine. For that reason I have kept my other machines back on older versions of Ubuntu. Is there a way to run older PHP versions in the newer Ubuntu releases, or will I have to change to another distro to do it? Thanks.

Manfred Hampl (m-hampl) said : #3

Can you go a bit into detail what "older PHP programs" means, what basic software they need etc.?

Are you aware that there are no patches delivered for Ubuntu 15.10 any more, not even for critical vulnerabilities?

rem (patterson) said : #4

I recall having had a problem running Netbeans for PHP when 16.04 came out. I just tried running my programs as they have been developed on 15.10 and they actually ran to completion without generating a swath of error messages--I exercised both command line PHP and webservice PHP with no immediately discernible problems. Perhaps whatever problem there was has been resolved. Perhaps there was a configuration issue with Netbeans. I'm going to upgrade Netbeans to its current release and retry these. This may resolve all! If so, I can upgrade my machine with Chrome and try to get it to launch again! Thanks.

Manfred Hampl (m-hampl) said : #5

If the PHP version that you need is not available (or not working) in Ubuntu 16.04, you might check going back to Ubuntu 14.04. Contrary to Ubuntu 15.10 this is still supported (until April 2019).
Also a nss version >= 3.26 is provided in Ubuntu 14.04.

Brian Read (brianr-bjsystems) said : #6

I have the same problem that Chrome will no longer run (since the latest chrome update), it gives:

FATAL:nss_util.cc(632)] NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer. Aborted (core dumped)

I am on 16:04

Manfred Hampl (m-hampl) said : #7

For diagnostic reasons please provide the output of the commands

uname -a
lsb_release -crid
apt-cache policy libnss3

i found myself the same issue today after i install ubuntu 16.04. But, did find a solution by

sudo apt-get install --reinstall libnss3

SOURCE: https://ubuntuforums.org/showthread.php?t=2178663

Brian Read (brianr-bjsystems) said : #9

This is the result of the commands

andrew@andrew-pc:~$ uname -a
Linux andrew-pc 4.4.0-28-generic #47-Ubuntu SMP Fri Jun 24 10:09:13 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
andrew@andrew-pc:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04 LTS
Release: 16.04
Codename: xenial
andrew@andrew-pc:~$ apt-cache policy libnss3
libnss3:
  Installed: 2:3.21-1ubuntu4
  Candidate: 2:3.21-1ubuntu4
  Version table:
 *** 2:3.21-1ubuntu4 500
        500 http://gb.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
andrew@andrew-pc:~$

Brian Read (brianr-bjsystems) said : #10

sudo apt-get install --reinstall libnss3

did not solve the problem.

Sourabh Jagtap (sourabh1995) said : #11

Hi,
i'm also facing the same issue, my whole project is on chrome and switching to another browser will not be good for me.

Error after running $ google-chrome
->
[10193:10231:0911/215202.846105:FATAL:nss_util.cc(632)] NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.
Aborted (core dumped)

output for -
$ lsb_release -crid
->
Distributor ID: Ubuntu
Description: Ubuntu 15.10
Release: 15.10
Codename: wily

$ apt-cache policy libnss3
->
libnss3:
  Installed: 2:3.23-0ubuntu0.15.10.1
  Candidate: 2:3.23-0ubuntu0.15.10.1
  Version table:
 *** 2:3.23-0ubuntu0.15.10.1 0
        500 http://in.archive.ubuntu.com/ubuntu/ wily-updates/main amd64 Packages
        500 http://in.archive.ubuntu.com/ubuntu/ wily-security/main amd64 Packages
        100 /var/lib/dpkg/status
     2:3.19.2-1ubuntu1 0
        500 http://in.archive.ubuntu.com/ubuntu/ wily/main amd64 Packages

If any one found solution, please let me know.

shadeslayer0 (shadeslayer0) said : #12

I am having this exact same issue and it's driving me nuts, nothing here has worked for me!

20:04 $ google-chrome
[15307:15345:0911/200404.498734:FATAL:nss_util.cc(632)] NSS_VersionCheck("3.26") failed. NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.
Aborted (core dumped)
✘-ABRT ~
20:04 $ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial
✔ ~
20:04 $ apt-cache policy libnss3
libnss3:
  Installed: 2:3.23-0ubuntu0.16.04.1
  Candidate: 2:3.23-0ubuntu0.16.04.1
  Version table:
 *** 2:3.23-0ubuntu0.16.04.1 100
        100 /var/lib/dpkg/status
     2:3.21-1ubuntu4 500
        500 http://gb.archive.ubuntu.com/ubuntu xenial/main amd64 Packages
✔ ~
20:04 $ sudo apt install --reinstall libnss3
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reinstallation of libnss3 is not possible, it cannot be downloaded.
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
✔ ~
20:04 $ uname -a
Linux shadeslayer-Lenovo-B50-80 4.4.0-38-generic #57-Ubuntu SMP Tue Sep 6 15:42:33 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
✔ ~
20:05 $

Manfred Hampl (m-hampl) said : #13

To rem (patterson) and shadeslayer0 (shadeslayer0):

You have to enable the xenial-updates repository as source for the package management system.
see https://help.ubuntu.com/community/Repositories/Ubuntu

and then install the updates that are offered (will be lots of them).

++++++++++++++++++++++

To Sourabh Jagtap (sourabh1995):
Ubuntu 15.10 is not supported any more. You have to upgrade to release 16.04.

I installed libnss3 and it worked. By the way, find the package version and system information below;

apt-cache policy libnss3
libnss3:
  Installed: 2:3.28.4-0ubuntu0.16.04.2
  Candidate: 2:3.28.4-0ubuntu0.16.04.2

NAME="Ubuntu"
VERSION="16.04.3 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04.3 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial

Can you help with this problem?

Provide an answer of your own, or ask rem for more information if necessary.

To post a message you must log in.