How do i play a file i made on noteedit?

Asked by MusicMagician98 on 2007-11-13

Everytime i press play nothing happens how come? sometimes the whole program freezesm after i press play, do you know hwy this happens?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu noteedit Edit question
Assignee:
No assignee Edit question
Last query:
2007-11-13
Last reply:
2009-06-05
Volker Paul (v.paul) said : #1

By default noteedit plays on MIDI hardware.
If none is attached to your computer, you won't hear anything,
but you can see it: the note just playing is marked red.
To hear the output without MIDI hardware,
install timidity and then in noteedit, go to
Settings - Configure Noteedit - Sound.
Choose Timidity port 0 as MIDI device.

Yaakov (ydalsace) said : #2

I had the same problem. Thanks for your answer. Noteedit seems to play something (each note becomes red), but I still don't hear anything. How could I check 1) that timidity works correctly, 2) that Noteedit effectively sends its output to timidity?

Thanks.

mibana (mballestern) said : #3

I d'ont speak english bat " He tenido el mismo problema y para poner los puertos de timidity hay que mirar en el acchivo que está en root/ etc/ default/ tymiditi y editarlo y modificar una linia que lleva un rem y por lo tanto no se ejecuta la llamada al ALSA . queitar el rem y guardar
 aactivar los puertos y luego reiniciar y ya funciona el sonido.
Yo tengo una pregunta. ¿ Como se indican en la partitura los "matices".

Yani Raafezaj (ytraaf) said : #4

Translation of what mibana said, for those of you who don't speak Spanish:

I've had the same problem and to set Timidity's ports you have to check the file that's in /root/etc/default/timidity and edit a line that's commented out with REM (which is why it doesn't call ALSA). Remove the "REM" and save it. Activate the ports and restart, and now the sound works.

Stoney (sjbird) said : #5

I tried Paul Volker's suggestion. It didn't help with the sound.

I looked for the file that mibana (Diego Argueta) referred to and didn't find any line referring to ALSA that was REMed.

I did find the following lines:

       # Enable MIDI sequencer (ALSA), default is enabled
       # Disable it if you have real MIDI hardware
       TIM_ALSASEQ=true

       # Setting overrides (of /etc/timidity.conf) for the ALSA sequencer daemon
       TIM_ALSASEQPARAMS="-Os"

Does something need to be changed there?

Yani Raafezaj (ytraaf) said : #6

Here's what I did to get it working:
1) Reinstall every ALSA module using Synaptic
2) Get timidity
3) Before running NoteEdit, TuxGuitar, etc., run this:

timidity -iA -Os&

and leave it open. The MIDI programs now work. When you're done, kill it with CTRL-C.

Yani Raafezaj (ytraaf) said : #7

Mibana: Creo que no se puede indicarlos en NoteEdit. Ahora uso MuseScore; le da muchísimo más control, y se puede instalar "sound fonts", con que se puede tocar la música pero con grabaciones de instrumentos actuales, no sintesisados.

Can you help with this problem?

Provide an answer of your own, or ask MusicMagician98 for more information if necessary.

To post a message you must log in.