how can i download the pkg , didnt manage to download it using apt-get install

Asked by sheri kettler on 2020-09-16

how can i download the pkg , didnt manage to download it using apt-get install

:~$ sudo apt-get install nlohmann-json3-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nlohmann-json3-dev

running the following ubuntu
Linux RDE101882620-1.3 3.2.0-53-virtual #81-Ubuntu SMP Thu Aug 22 21:21:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu nlohmann-json3 Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Manfred Hampl (m-hampl) said : #1

Your release of Ubuntu seems to be outdated (kernel version is from the year 2013)

What is the outout pf the command

lsb_release -crid

sheri kettler (sherikettler) said : #2

Thanks for your quick reply

lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 12.04.5 LTS
Release: 12.04
Codename: precise

-----Original Message-----
From: <email address hidden> <email address hidden> On Behalf Of Manfred Hampl
Sent: Wednesday, September 16, 2020 1:31 PM
To: Sheri Kettler <email address hidden>
Subject: Re: [Question #692944]: how can i download the pkg , didnt manage to download it using apt-get install

Your question #692944 on nlohmann-json3 in Ubuntu changed:
https://clicktime.symantec.com/3GK38ANUx6TdLVu1JXpx4hP6H2?u=https%3A%2F%2Fanswers.launchpad.net%2Fubuntu%2F%2Bsource%2Fnlohmann-json3%2F%2Bquestion%2F692944

    Status: Open => Needs information

Manfred Hampl requested more information:
Your release of Ubuntu seems to be outdated (kernel version is from the year 2013)

What is the outout pf the command

lsb_release -crid

--
To answer this request for more information, you can either reply to this email or enter your reply at the following page:
https://clicktime.symantec.com/3GK38ANUx6TdLVu1JXpx4hP6H2?u=https%3A%2F%2Fanswers.launchpad.net%2Fubuntu%2F%2Bsource%2Fnlohmann-json3%2F%2Bquestion%2F692944

You received this question notification because you asked the question.

Manfred Hampl (m-hampl) said : #3

Ubuntu 12.04 is not supported any more.
I recommend that you upgrade to a supported Ubuntu release.

The package nlohmann-json3 is available only for Ubuntu 20.04 and later, so I suggest that you upgrade to Ubuntu 20.04 LTS

see https://wiki.ubuntu.com/Releases for the different Ubuntu Releases and their support status.

Can you help with this problem?

Provide an answer of your own, or ask sheri kettler for more information if necessary.

To post a message you must log in.