How to disable wireless as default on a notebook?

Asked by tp42 on 2009-05-26

On startup, my Thinkpad X301 with Ubuntu Jaunty always connects to both ,the Ethernet and the wireless interface. Usually, I work on the Ethernet connection and do not need a wireless connection. So I would be happy to have the option to disable wireless by default in the network-manager applet. Is there a way to accomplish this, I have not found one yet. Any hints?
Thanks a lot in advance,
tp42

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
tp42
Solved:
2009-06-15
Last query:
2009-06-15
Last reply:
2009-06-01
Fethi DILMI (addictcook) said : #1

Click on the icon of Network Manager and go to the Wireless Tab and choose your connection , then click on Edit button , then uncheck the Connect Automatically Option.

Good luck ;) .

tp42 (45-spamex) said : #2

Hi Dilmi,
thanks for the hint, which is working for a particular WLAN connection.
However, I would like to have the whole wireless interface down as default, i.e. "Enable Wireless" unchecked as default setting in the network-manager applet.
Perhaps you know how to get this done?
Best regards,
tp42

Fethi DILMI (addictcook) said : #3

OK , go to System->Administration->Network .. then in that window click on unlock button. No Uncheck the wireless connection.

If the Network tool doesn't appear to you , install it using Applications->Add/Remove.. and in the title bar seek for "Network" , you'll find it (3 stars). Check it and Install and what I told you .

Good Luck ;)

tp42 (45-spamex) said : #4

Thanks Dilmi for the hints.
I had to install "Network" as you suggested. Then I tried what you told me. But, after unlocking the panels in Network, there is no possibility for me to uncheck or even check on of the check-boxes for wireless connection, wired connection or point-to-point connection. These options remain to stay grayed out. However, it seems, that some of the functions in Network are the same as the network-manager applet offers. Is there a possibility that both do the same in some way?
Besides that, are there some other possibilities to get the wireless interface staying down per default on startup?
Best regards,
tp42

Fethi DILMI (addictcook) said : #5

OK , no problem , you said you don't use you wireless connection too much , and you use the pppoe connection , so you've configured this latter using pppoeconf in terminal ;; we can conclude that you don't Network Manager so as to connect using pppoe connection. Therefore we are going to disable Network Manager from the startup:

Go to System->Preferences->Startup Applications and then uncheck the Network Manager program and close the window .... Now the network manager (which runs the wireless connection is deactivated from the startup , so in order to connect again using it you have only to run Network Manager temporary by System->Preferences->Network Connections and after you're automatically using the wireless connection.

Now after doing that you know that you connect to the ethernet connection by typing in terminal the sudo pon dsl-provider command.

Sorry for being late to post.

Good Luck;)

tp42 (45-spamex) said : #6

Thanks Dilmi for the hints.

It is right that I use my wireless connection not very much on my notebook. However, Ethernet I am using regularly. And I use NetworkManager all the time and I would rahter not like to diable it.
However, meanwhile I think I have found a workaround which is a handy solution for me:

I used the solution of #67614 (https://answers.launchpad.net/ubuntu/+source/network-manager/+question/67614), providing command line arguments to enable/disable the wireless network interface:

dbus-send --system --type=method_call --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.DBus.Properties.Set string:org.freedesktop.NetworkManager string:WirelessEnabled variant:boolean:false

false --> disable wireless
true --> enable wireless

In "Preferences>>Sessions>>Add" I added a new startup program:

Name: Wireless_Down

Command: dbus-send --system --type=method_call --dest=org.freedesktop.NetworkManager /org/freedesktop/NetworkManager org.freedesktop.DBus.Properties.Set string:org.freedesktop.NetworkManager string:WirelessEnabled variant:boolean:false

Comment: Disables Wireless network interface in network-manager-applet as default on start up

So far it works perfect, wireless is down by default on startup and could be enabled/disabled via Network Manager when needed.

Just one more question: Is there a way that Network Manager will offer such a posibility in future versions?

Fethi DILMI (addictcook) said : #7

I think it will offer that , because developers are working hard to correct errors and improve functionalities on it.

Good luck;)