Ubuntu

AR5001X+ Wireless Network Adapter [168c:0013] (rev 01) not working anymore using wicd after upgrading from Ubuntu 8.04 to Ubuntu 9.04

Asked by chris on 2009-05-09

I had Hardy Heron which was working fine with wicd.

Then I upgraded to Ubuntu 9.04 Wireless would no longer see my network.

So I connected via Ethernet cable. I did some searches and tried reinstalling wicd which did nothing.

Then I uninstalled wicd to see if the default network manager would work. Now it sees no devices and even plugging in does not work.

I've actually got purchased software on there and tons of data, so I do not want to to a complete wipe/reinstall. *sigh* Don't you hate it when an upgrade ends up costing hours and hours? kicking myself.

Question information

Language:
Italian Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
chris
Solved:
2009-05-09
Last query:
2009-05-09
Last reply:
2009-05-09
Hamood (hamuod) said : #1

Always run live cd first before upgrading to newer version.

Did you restarted the network ?

if you have pci wireless card remove and connect again.

Run the command lshw -C network to see if the wireless is detected or not.

I hope this helps?

Bye

Hi,

Please first connect your network card to the wireless router using an ethernet cable (also known as a LAN cable).

In order to gather essential troubleshooting information about your wireless card, please follow this procedure:

Step 1: Open Terminal from "Applications->Accessories->
Terminal"

Step 2: Run the following commands (copy-paste each line below to the Terminal then hit <enter> after each line)

cat /etc/lsb-release
sudo iwlist scanning
sudo lshw -C network
lspci -nn
lsusb
uname -a
dmesg | grep ound
dmesg | grep witch
iwconfig

Step 3: Please post results (copy/paste terminal output from each command) on this thread

Step 4: Please also specify the exact model and make of your PC (if known) on this thread

Keep in mind that one or more of the following 4 basic components need to be configured correctly so that wireless can work correctly in Linux:

Wireless configuration in the BIOS, hardware wireless switch setting, active wireless driver version, and firmware for the wireless chipset (stored as a file in Linux).

Regards,

Mark

chris (cjparis) said : #3

Hi,

Thanks very much for the help. I couldn't even connect vie Ethernet so I couldn't cut/paste. But after reinstalling wicd I am able to get on the network using wire, yay!

I have a Dell Inspiron 5150 with a P4 3GHz processor and 2 GB Ram, 35 GiB Har5d drive with 16.2 GiB free

OK so here are the commands entered and what the output was
<SNIP>
cparis@chris-laptop:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=9.04
DISTRIB_CODENAME=jaunty
DISTRIB_DESCRIPTION="Ubuntu 9.04"
cparis@chris-laptop:~$ sudo iwlist scanning
[sudo] password for cparis:
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan1 Interface doesn't support scanning : Network is down

pan0 Interface doesn't support scanning.

cparis@chris-laptop:~$ sudo lshw -C network
  *-network
       description: Ethernet interface
       product: BCM4401 100Base-T
       vendor: Broadcom Corporation
       physical id: 1
       bus info: pci@0000:02:01.0
       logical name: eth0
       version: 01
       serial: 00:0d:56:32:4d:2e
       size: 100MB/s
       capacity: 100MB/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=b44 driverversion=2.0 duplex=full ip=192.168.1.7 latency=32 link=yes module=ssb multicast=yes port=twisted pair speed=100MB/s
  *-network
       description: AR5001-0000-0000
       product: Wireless LAN Reference Card
       vendor: Atheros Communications, Inc.
       physical id: 0
       version: 00
       slot: Socket 0
       resources: irq:16
  *-network DISABLED
       description: Wireless interface
       product: Atheros AR5001X+ Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 1
       bus info: pci@0000:03:00.0
       logical name: wmaster0
       version: 01
       serial: 00:1f:33:d1:a3:46
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list logical ethernet physical wireless
       configuration: broadcast=yes driver=ath5k_pci latency=168 maxlatency=28 mingnt=10 module=ath5k multicast=yes wireless=IEEE 802.11bg
  *-network DISABLED
       description: Ethernet interface
       physical id: 2
       logical name: pan0
       serial: 26:ec:3d:eb:96:e3
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=yes multicast=yes
cparis@chris-laptop:~$ lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3580] (rev 02)
00:00.1 System peripheral [0880]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3584] (rev 02)
00:00.3 System peripheral [0880]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3585] (rev 02)
00:01.0 PCI bridge [0604]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to AGP Controller [8086:3581] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 [8086:24c2] (rev 01)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 [8086:24c4] (rev 01)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 [8086:24c7] (rev 01)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller [8086:24cd] (rev 01)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 81)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge [8086:24cc] (rev 01)
00:1f.1 IDE interface [0101]: Intel Corporation 82801DBM (ICH4-M) IDE Controller [8086:24ca] (rev 01)
00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller [8086:24c5] (rev 01)
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV34M [GeForce FX Go5200 64M] [10de:0324] (rev a1)
02:01.0 Ethernet controller [0200]: Broadcom Corporation BCM4401 100Base-T [14e4:4401] (rev 01)
02:04.0 CardBus bridge [0607]: Texas Instruments PCI4510 PC card Cardbus Controller [104c:ac44] (rev 02)
02:04.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCI4510 IEEE-1394 Controller [104c:8029]
03:00.0 Ethernet controller [0200]: Atheros Communications Inc. Atheros AR5001X+ Wireless Network Adapter [168c:0013] (rev 01)
cparis@chris-laptop:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:c521 Logitech, Inc. MX620 Laser Cordless Mouse
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
cparis@chris-laptop:~$ uname -a
Linux chris-laptop 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
cparis@chris-laptop:~$ dmesg | grep ound
[ 0.495664] ACPI: No dock devices found.
[ 0.516398] pnp: PnP ACPI: found 11 devices
[ 1.766842] isapnp: No Plug & Play device found
[ 2.204121] hub 1-0:1.0: USB hub found
[ 2.204506] hub 2-0:1.0: USB hub found
[ 2.204790] hub 3-0:1.0: USB hub found
[ 2.205080] hub 4-0:1.0: USB hub found
[ 2.208539] device-mapper: multipath round-robin: version 1.0.0 loaded
[ 2.210578] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
[ 3.072173] ssb: Sonics Silicon Backplane found on PCI device 0000:02:01.0
[ 15.523922] yenta_cardbus 0000:02:04.0: CardBus bridge found [1028:015f]
[ 16.221618] iTCO_wdt: Found a ICH4-M TCO device (Version=1, TCOBASE=0x1060)
[ 17.059335] ath5k phy0: Atheros AR2414 chip found (MAC: 0x79, PHY: 0x45)
[ 17.483632] lp: driver loaded but no devices found
cparis@chris-laptop:~$ dmesg | grep witch
[ 0.020732] SMP alternatives: switching to UP code
[ 1.051978] Switched to high resolution mode on CPU 0
[ 1.408412] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input0
[ 1.408725] ACPI: Lid Switch [LID]
cparis@chris-laptop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan1 IEEE 802.11bg ESSID:""
          Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
          Tx-Power=0 dBm
          Retry min limit:7 RTS thr:off Fragment thr=2352 B
          Power Management:off
          Link Quality:0 Signal level:0 Noise level:0
          Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
          Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

</SNIP>

chris (cjparis) said : #4

OK,
Thanks for talking me through entering those commands. When I looked at them and then at what I had in the wicd preferences I spotted what I thought could be the problem, and indeed it was.

"wlan1" was not entered in the textbox next to "wireless interface" in the wicd preferences. Once I typed that in, wicd knew what to use to look for the network. Then I was able to click [hidden networks], enter the SSID, fail, and then enter in the key. My wicd hung up after that, but on rebooting, I was able to connect to the wireless and I am back in business.

I'm not sure what in the upgrade caused that "wlan1" to go away, but typing it in was the "magic".

Thanks for your help!

Chris

Marco Diaz (zethabyte) said : #5

I have this problem but in ubuntu 10.10 with kernel 2.6.35-24-generic.

Wicd works fine with the 32-bit Ubuntu 11.10. I tried with Intel WiFi Link 5100.