Wired Network shows "cable unplugged" while it's plugged in

Asked by Zihang Ye on 2018-05-04

Hi,
I'm using Ubuntu 18.04. Everything was fine for a few days. But suddenly, after I woke up my laptop, I found that the cable icon on the gnome was gone. And in the Settings, it suggested that the cable was unplugged.
Every time I restart, the cable works well. But after some time, it will disappear again.
I've checked all possible answers on Ask Ubuntu. Nothing helpful.

I've checked the 'lshw -C network' command, and it's nothing different, except for the ip address, from the normal state.
I've tried to modify /etc/NetworkManager/conf.d/10-globally-managed-devices.conf , it doesn't work.
Using ifconfig, it suggests that it's up, broadcast, multicast.

Anyone can help? Thank you.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Last query:
2018-05-04
Last reply:
2018-05-04
A. Denton (aquina) said : #1

Zihang, I would recommend filing a bug report here and add your findings to it. I experienced the same with various versions, maybe for different reasons. I think someone should dive into it.

Have you tried a different cable?
Made sure the connection is OK on the non-system side. If there are alternative ports, try those too.... Its basically a computer too and isn't infallible.

Zihang Ye (jerry-yezihang) said : #3

I'm not sure whether I'm replying the right way...

A. Denton: can you please tell me what checkings should I do first so that I can give a bug report with enough information?

actionparsnip: Well, I'm using the same computer, the same cable, and the same internet as I've been using for two years. The problem is that this problem doesn't always exist. For example, I've just been back from school and now, due to a failure of gdm3, I relogged and everything works fine again! Isn't that weird?

The cable and port you are using needs exploring to remove it as a possible cause.

Zihang Ye (jerry-yezihang) said : #5

What do you mean by 'exploring to remove it'? Remove it physically? I've tried that. No use.
So you might think that it's a hardware problem? Is there anyway to prove it? Because otherwise, I'd rather believe that it's due to the software. When it was down yesterday, I've used several methods, which I forgot for now, and they showed correctly the information of my network adapter.

Different cables and different ports on the device you are connecting to. If the results are the same despite the changes then we know it's not this causing the problem

Zihang Ye (jerry-yezihang) said : #7

Sorry for not replying. But since this is a problem that I can't reproduce ( I have to wait until it disables itself) and it's been working well for three days, I'll keep the question like this. If it happens again, I'll update it here with my tests with different cables.

adin (adin-rivera) said : #8

I'm experiencing a similar problem after upgrading from 17.10 to 18.04.

Network cable and connection work as expected. It connects and works with other computers.

The same connection worked with the previous installation 17.10, I just did an upgrade to 18.04 and the wired connection says that the cable is not plugged.

Please advice which information do you need to help debug the problem.

Artem Baguinski (femistofel) said : #9

I'm experiencing the same problem.

Wired network works for a short time after a reboot.

Restarting services `networking` or `network-manager` doesn't help.

I have the same problem. It is OK after reboot but after a while it says "cable unplugged". This is the output of lshw -c network.

       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: enp2s0
       version: 09
       serial: ac:9e:17:4a:b6:4d
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168f-1_0.0.5 06/18/12 ip=192.168.0.50 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:36 ioport:d000(size=256) memory:d2104000-d2104fff memory:d2100000-d2103fff

Can you help with this problem?

Provide an answer of your own, or ask Zihang Ye for more information if necessary.

To post a message you must log in.