nm-applet wants access to keyring

Asked by cirobr


I've just made a clean install of Ubuntu Intrepid to my notebook. All updates in place.

Connection to an open WiFi AP is perfect. When connecting to a WPA AP, the following happens:
* The password for the AP is requested and entered.
* Then, it is requested a password for the standard keyring. Entered.

Now, every time I reboot, the keyring password is requested. When entered, WPA connection is established.

Any hint on how to get rid of this?


Question information

English Edit question
Ubuntu network-manager Edit question
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Last query:
Last reply:
Revision history for this message
cirobr (ciro-rosa) said :

On /home/.gnome2/keyrings folder there are two files: "default" and "default.keyring". Changing permissions with "chmod 666" and "chmod 777" for both gave no result.

Revision history for this message
cirobr (ciro-rosa) said :

I've now created an area for a new user. User privileges. I've just been requested to enter WPA password. Now, every time I restart and enter on the new user area, no password is requested and WPA WiFi works perfectly.

After restarting and entering on my own area, the standard keyring password is requested! One difference from previous attempts: One checkbox was shown on the window which requests the keyring password: it said that, when checked, no further request to keyring password would be made. Indeed, it is now behaving like that.

Now, every time I reboot and enter to any of the user areas, no WPA or keyring password is requested.

It is worth to say that before reporting this bug I've made three clean installations of Intrepid, all with same initial problem - so it is repeatable.

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
cirobr (ciro-rosa) said :

Need to re-open the case, as the "workaround" of creating a new user is neither professional nor repeatable. any help is appreciated.


Revision history for this message
Best marcobra (Marco Braida) (marcobra) said :

I found network-manager has some bugs
I have a network issue like your and i have installed wicd to resolve it. Wicd is a different network tool.

http://wicd.sourceforge.net/ and some screenshot http://wicd.sourceforge.net/screenshot.php

How to install wicd

Open a Terminal from the menu Applications → Accessories → Terminal and type:
(if the system ask you for a password give your user password, you will not see nothing when you type it, then press enter)

wget -q http://apt.wicd.net/wicd.gpg -O - | sudo apt-key add -

Add the wicd repository row to your /etc/apt/sources.list, type:

sudo gedit /etc/apt/sources.list

and add this row:

deb http://apt.wicd.net intrepid extras

save close and exit. Then type:

sudo apt-get update
sudo apt-get install wicd
sudo killall nm-applet

To manually run the wicd-client please press Alt+F2 on an empty desktop and insert this command:


configure your connection. Then reboot your pc.

Hope this helps

Revision history for this message
cirobr (ciro-rosa) said :

Thanks marcobra, that solved my question.

Revision history for this message
Chuck (chux-industryinet) said :

Thanks marcobra and everyone. This worked great for me. Clear, complete instructions. Thanks

Revision history for this message
kapilajayanath (kapilajayanath) said :

Hi, I successfully installed wicd. But it doesn't show any activity (doesn't flash) even when I ping to a local IP. Please help me to resolve this.