No static IP on Ubuntu Intrepid 8.10

Asked by jokker

After upgrading from Hardy to Intrepid, /etc/network/interfaces was ignored, no matter what I tried, this file was ignored by Intrepid. I ended with a dynamic IP address. I thought it was related to the upgrade, so I reinstall everything and kept my /home. Same problem, no static IP possible but this time /etc/network/interfaces was empty, only the loopback was present, but I still had connection / internet through dhcp. This particular machine and 2 others MUST be in static IP (I only use dhcp on my 2 laptops). So I edited /etc/network/interfaces like this:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static

auto eth1
iface eth1 inet static

But after a reboot (to test the settings completely) no access to internet, though I could still ping the router, DNS I thought!

I edited /etc/resolv.conf, but everything was already there !!!!!:

# Generated by NetworkManager

(checked and compared to my modem interface, these above are OK DNS IPs)

I tried to remove NetworkManager from rc.d but it did not change anything, so I restore NetworkManager defaults in rc.d

So at this point I had the correct IP settings, but no DNS working... Seemed like this time /etc/network/interfaces was no longer ignored but /etc/resolv.conf now is !!!!!

So right now I'm back to DHCP, I commented all about eth0 and eth1 in /etc/network/interfaces and restarted... Everything works beside the fact that I have wrong IP addresses for both NICs.

I feel like I'm going crazy, I spent the last 72 hours practically day and night on this, I NEED THIS MACHINE TO WORK since I use it as a server (ssh, apache, ftp, VPN, samba, cups, NFS) and guess what... Everything is setup with IP, not hostnames... That means all the servers are down. So far this is the worst experience I had with Ubuntu, "the number one distro" people say...

Thanks for your help

Question information

English Edit question
Ubuntu network-manager Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Daniel Hollocher (chogydan) said :

try removing the package network-manager*

I think there are problems with nm and static ips.

Revision history for this message
jokker (david-las-solanas) said :

I thank you for your help but that was a very very bad idea, let me explain...
After sudo aptitude remove network-manager*, I uncommented all about eth0 and eth1 in my very good interfaces file then rebooted... NO internet, no dns, but eth0 and eth1 worked and had correct static IPs, so no change... I tried to reinstall network-manager but without DNS I had to download it for another machine, a laptop with Sabayon Linux (very good distro byt the way) and then reinstall it through scp to go back to zero, so you can scratch that solution, it does not do any good.

Revision history for this message
jokker (david-las-solanas) said :

If you have wrong IP setting, it seems like you need to enter them manually in system - preferences - network connection... then in the nm-applet on the top bar right click on it and uncheck "enable connection" then recheck it: IT WORKS as long as you do not restart your machine. For some reason it works better than # /etc/init.d/networking restart or even # ifup ethx
That's my solution for now, I hope to get a fix very soon.

Revision history for this message
Daniel Hollocher (chogydan) said :

well, you could have just set your interfaces back to dhcp again, couldn't you? Anyway, sorry that you are having so much trouble.

personally, I think you should go back to hardy. Anyway, good luck.

Revision history for this message
jokker (david-las-solanas) said :

If I go back to DHCP my IP address will be *.51 or *.52 I set only 2 IPs for dhcp and they are for my laptops, and no I do not want to change all my router's settings, because then I will have to change a lot more things on all my stations (and even more than that). This machine must be *.22 It's a long story... I think I will go back to hardy because this is really a mess and I have a backup, but I still want to give it a try, Intrepid "looks" good. Thank for your help.
Is there anybody working on this bug already? How can I know?

Revision history for this message
jokker (david-las-solanas) said :

Any news on this ?

Revision history for this message
jokker (david-las-solanas) said :

I'm now sure this bug comes for the new network-manager that comes with Ubuntu Intrepid 8.10
But I can't find a way to fix it.

Revision history for this message
Alexander Sack (asac) said :

I think this is rather a question than a bug?

static interfaces are supported in general. there are a few bugs surrounding auto startup and configuring them as system connections open. However, things in /etc/network/interfaces are not managed by NM, so when those dont come up its a different issue.

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
jokker (david-las-solanas) said :

Well I still have the bug, and one more time: this was not a question. Anyway, some serious people may fix it one day and release the fix on some official update. Thanks for nothing...

Revision history for this message
frankO (frank-grant) said :

Have a look at
It shows two ways to set up a static ip in 8.10

Revision history for this message
Me2resh (me2resh) said :
Revision history for this message
jokker (david-las-solanas) said :

Unfortunately this won;t help. I have been using interfaces without any problem since the bug is out there but only one NIC has to be enabled, the other is not working. If I enable both one is not working (randomly eth0 or eth1) if I enable eth0 and comment eth1, eth0 works. If I enable eth1 and comment eth0, eth1 works. SO like I said above, this is a bug not a question but no one gives a damn. It seems to be an issue with DNS resolution when 2 NICS are enabled to work together on intrepid. I will wait a few more weeks for this bug to be fixed and move on to Sabayon Linux on these stations otherwise like I have on my laptops for 2 years now...

Revision history for this message
TM Elmo (crookedscum) said :

I so hate to reconfigure my static eth1 every time i start my box ... but this web site solved my problem, especially the recurring DNS issue of dhcp rewriting my /etc/resolv.conf file.

hope this helps ...

Revision history for this message
David A. Cobb (superbiskit) said :

I'm finding similar problems. For security reasons, I wish to change from DHCP to static, and set up my router so only IP's that I assign work -- keeping the neighbors from piggybacking my account.

First I tried in network-manager and had the issues described above -- I could manually set the desired IP and have it work, but it wouldn't survive reboot. So I prowled around and found that network-manager really isn't happy with static IP's, although it might be coerced into working. Anyway, the schema files for the GCONF entries aren't provided with the distro, and I wasn't feeling that brave.

So, I removed network-manager and configured /etc/network/interfaces roughly as described in the OP. And had the same result. I could not resolve any addresses, but I could ping on nodes whose IP I know.
At that point, I punted and reset /etc/network/interfaces for DHCP. It works, but I'm still not happy with it.

Revision history for this message
Taza Gul (tazagul) said :

I am fully up-to-date on all upgrades and this problem has persisted. I setup a static address through Network Manager and it was frustrating to see it revert to Auto after every reboot, especially since it gave me the wrong gateway and DNS.

The easiest solution I have found to this problem is to remove the DHCP client through Synaptic and it will skip Auto and go to the static setting I have setup. Since this is a desktop, this is a viable solution, with a laptop, this would be limiting. As a note, I didn't try to remove all the associated packages, just the main DHCP client.

Revision history for this message
Mike Smith - dominoconsultant (dominoconsultant) said :

I am also having this same problem. This has got to be reported as a bug. How do we do that?

Revision history for this message
marcobra (Marco Braida) (marcobra) said :

There is already a bug report about this:
i temporary switched to wicd to get rid of this issue:

I have a network issue like your and i have installed wicd to resolve it. Wicd is a different network tool. and some screenshot

How to install wicd

Open a Terminal from the menu Applications → Accessories → Terminal and type:
(if the system ask you for a password give your user password, you will not see nothing when you type it, then press enter)

wget -q -O - | sudo apt-key add -

Add the wicd repository row to your /etc/apt/sources.list, type:

sudo gedit /etc/apt/sources.list

and add this row:

deb intrepid extras

save close and exit. Then type:

sudo apt-get update
sudo apt-get install wicd
sudo killall nm-applet

To manually run the wicd-client please press Alt+F2 on an empty desktop and insert this command:


configure your connection. Then reboot your pc.

Hope this helps

Can you help with this problem?

Provide an answer of your own, or ask jokker for more information if necessary.

To post a message you must log in.