[Intrepid][Regression] CNet CWP-854 (rt61pci)- Network manager can't connect to access point

Asked by Aaron Whitehouse on 2008-06-01

This was working perfectly on Intrepid Beta and has regressed to not working when I try the Intrepid Final Live CD.

Network-manager cannot connect to my access point, even when I disable all security (both MAC filtering and encryption - it is now completely open). I have no issues connecting with an IPW2200. When I put in the WPA2 AP passphrase, the icon spins for a while and then fails.

Can anybody help me figure out where the issue is?

The driver is "rt61pci".

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Aaron Whitehouse
Solved:
2008-11-06
Last query:
2008-11-06
Last reply:
2008-06-17

I've been reading:
http://rt2x00.serialmonkey.com/wiki/index.php?title=Main_Page
and
http://ubuntuforums.org/showthread.php?t=252951

And it looks to me as though the Rt2x00 driver should be in the Hardy kernel. Doesn't that mean that the Hardy kernel/network manager should work with WPA2 networks?

According to:
http://rt2x00.serialmonkey.com/wiki/index.php?title=Hardware
this card is a Realtek 2500 chipset.

Reading:
http://rt2x00.serialmonkey.com/wiki/index.php?title=FAQ
I'm wondering if my issue is that the current driver is the legacy one and doesn't support WPA Supplicant (used by network-manager) and I need to wait until the 2x00 driver is used for the 2500. That doesn't seem right, though, because I thought the Hardy kernel had the 2x00 driver...

Other links for reference:
http://ubuntuforums.org/showthread.php?t=563547
http://ubuntuforums.org/showpost.php?p=3595458&postcount=6
http://johnorford.blogspot.com/2007/06/rt2500-wpa-ubuntu-feisty-howto.html

This question is really a bit too old to be useful:
https://answers.launchpad.net/ubuntu/+source/network-manager/+question/5775

And this bug was fixed
https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.22/+bug/134660

It seems like nearly all the information is for old Ubuntu releases (which didn't include the 2x00 driver in the kernel), so shouldn't really be relevant (I wouldn't have thought).

Any help would be really appreciated - I just donated to the project, if that makes anyone more inclined to give me some tips :)!

Knut Karevoll (gnonthgol) said : #4

If you wonder if your wireless card is installed try to run 'iwconfig' in a terminal. The output should show information on at least one interface.
Another problem could be your configuration. You can configure the AP to not send out the ssid. Then Ubuntu will need some help with finding the AP. Select 'Other Wireless Network' in the network applet in the top right and enter the ssid.

Hi Knut,

You were right, the card was not correctly installed (nothing showed up in lspci), so I reinserted the card and I am a lot better off. Now I can see wireless networks in the network-manager list, but cannot connect to them.

I have opened my AP up completely, but this still doesn't solve the issue.

Read this:
https://bugs.launchpad.net/ubuntu/+source/linux-ubuntu-modules-2.6.22/+bug/134660
http://ubuntuforums.org/archive/index.php/t-600148.html

According to:
http://live.gnome.org/NetworkManagerHardware
Driver: rt2x00
Status:
Supports unencrypted and WEP networks when used with NetworkManager. While the driver supports WPA, it does not use Linux Wireless Extensions for WPA support, which is required for NetworkManager. Note: WPA/WPA2 is working since kernel-2.6.22 with the new Wireless-Stack and the latest rt2x00 CVS version.

I tried wicd
http://wicd.sourceforge.net/download.php
but it sits at the "Obtaining IP Address..." screen until it times out (with the AP set on unsecured or WPA2 security).

https://help.ubuntu.com/community/WifiDocs/Driver/RalinkRT2500 says that:
In Ubuntu 7.10 (Gutsy Gibbon) everything should work out of the box, using newer built-in driver, so the information posted below are not relevant to this version. There are many reports about WPA connections not working, though. [WWW] This post describes how to make them work by going back to the legacy serialmonkey driver. The issue was reported in the [WWW] bug #134962.

So it should be working...

I filed this:
http://rt2x00.serialmonkey.com/phpBB/viewtopic.php?f=5&t=4827
in the forum, hoping that somebody can help.

Launchpad Janitor (janitor) said : #9

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

This is fixed out-of-the-box in Intrepid Alpha 4. Thanks everyone!!!

Switching to solved - hopefully it is still fixed in the Intrepid Final :).

Ah darn... This was working fine in Intrepid Beta and is broken in Intrepid Final! What happened???

I have tested the Live CD only, but am not overly keen to install it unless something has actually changed that may fix it (I want to change a number of PCI cards before I reinstall, but that requires getting rid of the wired network card).

Probably best to ignore this chain - up to date information is in the Bug. It looks like this could be a Mythbuntu issue.