Ubuntu update 15.04 now no network enp3s0

Asked by Pok Salid on 2015-11-09

New to Ubuntu and very upset that a system update killed my Ethernet network. Thank god I have this old windows laptop to find help. It appears that eth0 has a new build enp3s0. Nice... no fore warning no options, just throw the d*mn thing into the system and let everyone else worry about it. That is P!ss Poor Programming.

I found a video on youtube that helped me get my ethernet up...But on reboot the damn thing crashed again. I tried system recovery from backup, crashing the program to rebuild....nothing helped it just comes back..saying you have the latest update installed....thanks WiFi on my combo card works and I can print to my network printer.

/etc/network/interfaces - edited to Auto enp3s0 /// iface enp3s0 inet static /// adresses and masks set to my system

Resolv.conf edited to map? networks - it worked but file was reverted back after reboot.

reboot and Ethernet Network device not managed error

/etc/networkManager/NetworkManager.conf Managed=false //// Ethernet Network device not managed ----error
/etc/networkManager/NetworkManager.conf edited to list Managed=true

back to no network

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Last query:
2015-11-10
Last reply:
2015-11-11

This question was originally filed as bug #1514498.

Pok Salid (holmes-la) said : #1

How can I get my Ethernet Network back on line when the update changed Eth0 to Enp30?

If you add your network to the interfaes file then network manager cannot touch it

Pok Salid (holmes-la) said : #3

Yes I considered that and set everything to what it was before I made changes. Still the same will not acknowledge my network . Goto Settings>Network ..... " The system network services are not compatible with this version"

Pok Salid (holmes-la) said : #4

my set up, just me and router

/etc/network/interfaces youtube…

# interfaces(5) file used by ifup(8) and ifdown(8)

auto enp3s0
iface enp3s0 inet static

address 192.168.0.120
netmask 255.255.255.0

network 192.168.0.169
broadcast 192.168.0.255
gateway 192.168.0.169

Pok Salid (holmes-la) said : #5

My Default settings

pok@pok:~$ ifconfig -a
enp3s0 Link encap:Ethernet HWaddr 40:16:7e:68:5f:d1
          inet6 addr: fe80::4216:7eff:fe68:5fd1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:13787 errors:0 dropped:1 overruns:0 frame:0
          TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1016847 (1.0 MB) TX bytes:4789 (4.7 KB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:65536 Metric:1
          RX packets:8215 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8215 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:639643 (639.6 KB) TX bytes:639643 (639.6 KB)

wlp2s0 Link encap:Ethernet HWaddr d8:fc:93:f3:bf:97
          BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

pok@pok:~$

pok@pok:~$ iwconfig
enp3s0 no wireless extensions.

wlp2s0 IEEE 802.11abgn ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=off
          Retry short limit:7 RTS thr:off Fragment thr:off
          Power Management:off

lo no wireless extensions.

pok@pok:~$

The network address is:

192.168.0.0

Pok Salid (holmes-la) said : #7

Router and gateway 0.169
computer 0.120

Pok Salid (holmes-la) said : #8

Aha! network-manager and network-manager-gnome is missing or is obsoleted.... hummm all day and this is what i find. what is next?

Manfred Hampl (m-hampl) said : #9

Please provide the output of the terminal commands

uname -a
lsb_release -crid
dpkg -l | grep network
sudo dpkg --audit

I am a bit astonished to read that you have network cards with the enp3s0 naming standard on Ubuntu 15.04.
I though that the change from eth0 naming standard to enp3s0 naming standard was introduced only in Ubuntu 15.10 - and even there not for upgraded systems but only for new installations.
Have you done some specific tuning of your system (e.g. adding the net.ifnames=1 boot parameter)?

Pok Salid (holmes-la) said : #10

Will do when I get home. It appeared on my side bar. A green icon showing system update. I thought, humph...Ok. at this time I have no network-manager nor gnome. I downloaded NM and NMG, then nmlib0.....piece by piece..... I'm still missing some libraries will have to do that later too. I havea combination Eth, Wfi, Bluetooth card with coaxial antenna, found on Amazon.
Would it be better to wipe my hard drive and start over with 15.10?
How can I do this? I have a 1tb Seagate baracuda hd.

Manfred Hampl (m-hampl) said : #11

If you are interested in a stable system without the need of upgrading to a new release twice a year, you better stick to the LTS (long term support) versions of Ubuntu. The last one was 14.04, and there will be a new LTS release 16.04 be published in April 2016.

If you burn the installer .iso file to a DVD or create a bootable USB stick with it and boot with such device, the installer should offer you the choice to overwrite the already-installed Ubuntu system. (Note, you have to create backup copies of all your important files to another device before overwriting the old installation!)

Pok Salid (holmes-la) said : #12

Ok I'll try that. 15.04 original would only let me rebuild with current updates. I'll try 14.04 or another.

Pok Salid (holmes-la) said : #13

pok@pok:~$ uname -a
Linux pok 4.1.0-2-generic #2-Ubuntu SMP Wed Jul 22 18:19:08 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
pok@pok:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 15.10
Release: 15.10
Codename: wily
pok@pok:~$

pok@pok:~$ dpkg -l | grep network
ii avahi-autoipd 0.6.31-4ubuntu4 amd64 Avahi IPv4LL network address configuration daemon
ii glib-networking:amd64 2.45.1-1 amd64 network-related giomodules for GLib
ii glib-networking-common 2.45.1-1 all network-related giomodules for GLib - data files
ii glib-networking-services 2.45.1-1 amd64 network-related giomodules for GLib - D-Bus services
ii ifupdown 0.7.54ubuntu1 amd64 high level tools to configure network interfaces
ii iproute2 4.1.1-1ubuntu1 amd64 networking and traffic control tools
ii iputils-ping 3:20121221-5ubuntu2 amd64 Tools to test the reachability of network hosts
ii iputils-tracepath 3:20121221-5ubuntu2 amd64 Tools to trace the network path to a remote host
ii libgroupsock1 2014.01.13-1 amd64 multimedia RTSP streaming library (network interfaces and sockets)
ii libkf5kiocore5:amd64 5.15.0-0ubuntu2 amd64 Resource and network access abstraction.
ii libkf5kiowidgets5:amd64 5.15.0-0ubuntu2 amd64 Resource and network access abstraction.
ii libnm-glib-vpn1:amd64 1.0.4-0ubuntu5 amd64 network management framework (GLib VPN shared library)
ii libnm-glib4:amd64 1.0.4-0ubuntu5 amd64 network management framework (GLib shared library)
ii libnm-gtk-common 0.9.10.1-0ubuntu7 all network management framework (common files for wifi and mobile)
ii libnm-gtk0:amd64 0.9.10.1-0ubuntu7 amd64 network management framework (GNOME dialogs for wifi and mobile)
ii libnm-util2:amd64 1.0.4-0ubuntu5 amd64 network management framework (shared library)
ii libproxy1-plugin-networkmanager:amd64 0.4.11-4ubuntu2 amd64 automatic proxy configuration management library (Network Manager plugin)
ii libqt4-network:amd64 4:4.8.6+git64-g5dc8b2b+dfsg-3~ubuntu8 amd64 Qt 4 network module
ii libqt5network5:amd64 5.4.2+dfsg-2ubuntu9 amd64 Qt 5 network module
ii net-tools 1.60-26ubuntu1 amd64 NET-3 networking toolkit
ii netbase 5.3 all Basic TCP/IP networking system
iU network-manager 1.0.4-0ubuntu5 amd64 network management framework (daemon and userspace tools)
iU network-manager-gnome 0.9.10.1-0ubuntu7 amd64 network management framework (GNOME frontend)
ii network-manager-pptp 0.9.10.0-1ubuntu1 amd64 network management framework (PPTP plugin core)
ii network-manager-pptp-gnome 0.9.10.0-1ubuntu1 amd64 network management framework (PPTP plugin GNOME GUI)
ii oneconf 0.3.8 all synchronize your configuration data over the network
ii oneconf-common 0.3.8 all synchronize your configuration data over the network
ii python-oneconf 0.3.8 all synchronize your configuration data over the network (Python 2)
ii python3-oneconf 0.3.8 all synchronize your configuration data over the network (Python 3)
ii tcpdump 4.7.4-1ubuntu1 amd64 command-line network traffic analyzer
pok@pok:~$

pok@pok:~$ sudo dpkg --audit
sudo: unable to resolve host pok
[sudo] password for pok:
The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 network-manager network management framework (daemon and userspace tools)
 network-manager-gnome network management framework (GNOME frontend)

pok@pok:~$

pok@pok:~$ sudo dpkg --configure network-manager network-manager-gnome
sudo: unable to resolve host pok
[sudo] password for pok:
dpkg: dependency problems prevent configuration of network-manager:
 network-manager depends on libnm0 (>= 1.0.4-0ubuntu5); however:
  Package libnm0 is not installed.

dpkg: error processing package network-manager (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of network-manager-gnome:
 network-manager-gnome depends on network-manager (>= 0.9.10); however:
  Package network-manager is not configured yet.

dpkg: error processing package network-manager-gnome (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 network-manager
 network-manager-gnome
pok@pok:~$

Manfred Hampl (m-hampl) said : #14

Ok, it seems that for whatever reason some networking packages are not correctly installed.

What is the output of

sudo apt-get install -f

and if that fails, the output of

apt-cache policy libnm0
sudo apt-get install libnm0 -f

Pok Salid (holmes-la) said : #15

Its gone...I think. I downloaded 14.04 and tried to install it. Old install will not go away..arguh!! Looked all morning for a way to wipe my hard drive....nightmare. I looked for Grub commands, couldn't make head way there. Found a dd comand and it seems to be working and right at this moment I finally got a black screen....Yeah!!!

I have to go to work now and will try a fresh install on 14.04 this evening.

Pok Salid (holmes-la) said : #16

Update: The DD command put all zeros on hard disk and I have yet to recover the drive. Tried to boot with Installation disks and programs and nothing boots. If I may refrence a video that totally fits. https://www.youtube.com/watch?v=3WBjF4Ijvj4

I purchased Neosmart Recovery essentials which booted and helped. The bootmgr is missing and I am running Gparted and getting an error /dev/ada0 - Inappropriate ioctl for device.
Partition showing /dev/ada0p1 Hummm. So I can run Fdisk and it says Warning: Bios sector numbering statrs with sector 1
Cannot run ChkDsk, maybe Neosmart can help, I'll check with them.

I have a new hard drive arriving today and hopefully it will be plug and play. Not sure why installation OS's would not load when primary hard drive needs repair, ie boot sector.

I was able to partially boot Win2000 but it went to a blue screen when it found errors in the hard drive.

Can you help with this problem?

Provide an answer of your own, or ask Pok Salid for more information if necessary.

To post a message you must log in.