[Request] l2tp for network-manager or other way GUI

Asked by a666666a

Some internet providers use l2tp for internet connection. This is well known problem for many Russian users. For example - one of "big 3" Russian providers use this damned l2tp: http://en.wikipedia.org/wiki/Beeline_%28telecommunications%29 .

Now we have some variants to connect this way, but one and only decision "from the box" is to remove network-manager and make many movements to configure xl2tpd - not friendly if you understand what i'm talking about.

Other variants is to use some software not from official repositories, you can easily find them https://www.google.ru/search?q=ubuntu+l2tp .

6-7 years i tried all those different ways and they work (not best way, but they still working). I had no problem with l2tp on Windows from XP and till W7 - working fine (with IPsec and without - no problem, just on XP need some reg file you need to download or create in notepad and click to add changes to win-registry).

Any new Ubuntu release i check one thing first: is there any normal friendly way from the box to connect to internet using l2tp. Of cause first time i look at network-manager options. And next step search the web. Still nothing i saw for 13.04.

I understand that this is maybe in most cases only local Russian problem, but this is real problem when you want to say to friend "hey, use Ubuntu - solid OS with friendly user interface". I can't say it to most my friends that use providers with l2tp.

Something like a half year before (last "check point" was 12.10) i found the l2tp plugin for network-manager, plugin working fine with internet, but:
1) no official support here
2) you need to add his repo - this is still not friendly and security risks you know
3) at this moment 13.04 not supported
4) hard way for users that have no other way to connect to internet except l2tp - they need to download all needed packages from other OS and install them step by step, i believe that this is "very not friendly" if you check dependencies.
5) working fine without IPsec, but with IPsec not working. In my situation i have:
a) internet provider use l2tp if you want good speed - i need l2tp
b) RDP use l2tp with IPsec tunnel too - now i can remotely work only from Windows.

plugin link: https://launchpad.net/~seriy-pr/+archive/network-manager-l2tp

I believe that Ubuntu need some normal friendly GUI for work with l2tp, same as we have for PPTP + maybe IPsec.

Question information

English Edit question
Ubuntu network-manager Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

You can report a bug and/or post on the ubuntu brainstorm site

Revision history for this message
a666666a (a666666a) said :

Thank you, i tied this service too: http://brainstorm.ubuntu.com/idea/30774/

Can you help with this problem?

Provide an answer of your own, or ask a666666a for more information if necessary.

To post a message you must log in.