nmcli does not connect

Asked by Ishan A B Ambanwela on 2013-01-05

when I try to connect with connection named Hutch

nmcli con up id Hutch

** (process:21044): WARNING **: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/19: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

** (process:21044): WARNING **: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/19: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

but if I remove the dongle and if re connect to the PC it works.I can not reconnect after disconnect the same connection

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Last query:
2013-01-15
Last reply:
2013-01-05

What is the output of:

lsb_release -a; uname -a

Thanks

Ishan A B Ambanwela (ishanaba) said : #2

ishan@ishan-laptop:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
ishan@ishan-laptop:~$ uname -a
Linux ishan-laptop 3.2.0-35-generic #55-Ubuntu SMP Wed Dec 5 17:42:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

If you are connecting to a wifi network and not 3G, I recommend you use Wicd. It has a lovely ncurses UI.

Ishan A B Ambanwela (ishanaba) said : #4

I am connecting to a 3G network.

very first time i can connect to network without any problem.

but after disconnect(with out unplug dongle) using nmcli or nm-appletI can not connect again.

if only I unplug the dongle and re-plug I can reconnect to network.
further if i restart or log out and again if it works well.

problem occurs only when connect and disconnect several times with in the same session.

N1ck 7h0m4d4k15 (nicktux) said : #5

Maybe this is a bug and should report like one.

or maybe needs sudo privileges ? Have you tried with sudo ?

or maybe you missed something.. read the description from nmcli manual page

" Activate a connection. The connection is identified by its name using id or UUID using uuid. For requiring particular
                     device to activate the connection on, iface option with interface name should be given. "

Maybe the correct command is something like below

nmcli up id <id> <iface>

Thanks

Ishan A B Ambanwela (ishanaba) said : #6

@NikTh

no it also does not work.
and I am a sudo user and do not need privilages to connect to a network.
commands were correct.because, first time it works.

I noticed this occurs after updating from 12.04 to 12.04.1.
previously this was working
I do not know what update exactly did this.
I might create a bugreport.

Thanks

Can you help with this problem?

Provide an answer of your own, or ask Ishan A B Ambanwela for more information if necessary.

To post a message you must log in.