Ubuntu 12.04 after update Network icon missing

Asked by Ajay Srinivasan on 2012-08-13

After update and restart, the network icon is missing in the top panel and when i select 'network' from the unity dash home, I get an error saying that 'The system network service is not compatible with this version'
I tried 'sudo service network-manager start ' and 'sudo NetworkManager' 'sudo network-manager'
it gives error that command not found. please help me out here. Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-08-15
Last query:
2012-08-15
Last reply:
2012-08-15

This question was reopened

That's because network-manager isn't a service. If you attempt to guess commands you will more than likely fail. Also using capitalization will nearly always fail as there are only a handful of commands with capital letters in and Linux is VERY case sensitive.

Can you please give the output of:

lsb_release -a; uname -a; apt-cache policy network-manager

Thanks

No, this is simply indicative of an incomplete upgrade -- the version of NetworkManager doesn't match with a version supported by the nm-applet or the control-center applet that is installed. You may want to run 'sudo apt-get install -f' or start upgrades again to see if there are new updated packages available.

'sudo service network-manager start' is suboptimal, but should work. The best way to stop, start and restart the NetworkManager service, however, is:

sudo start network-manager
sudo stop network-manager
sudo restart network-manager

Each of these commands will do as the second word says; start, stop, or restart the service.

http://www4.picturepush.com/photo/a/8965757/220/8965757.png

this is my output for andrew's commands.
And mathieu, i don't have network connectivity..that is the problem. So, i can't sudo update

Can you copy the text, the image you gave is microscopic but is also just text...so you can paste that here and an image isn't needed.

Since, i don't have connectivity in laptop, I am using a mobile now..i cannot type everything shown on my screen..so, i thought a screenshot will help..wait..i'll double check the image or post another screenshot..

Try pressing ALT+F2 and run:

nm-applet

The system is a laptop. Did you not think to use a WIRED connection and reinstall network manager there?

dear andrew,
 any connection to outside network, be it lan or wifi , everything is blocked. i tried plugging lan cable , usb modem .. but no use.

i tried nm-applet. it says , 'the program nm-applet can be found in the following packages:
*network-manager-gnome
*mythbuntu-diskless-client
Try: sudo apt-install <selected package>'

Connect to a wired network and reboot. Log in then open a terminal and run:

gksudo gedit /etc/resolv.conf

delete all text and add:

nameserver 8.8.8.8

Save the new file and try the web.

i plugged in lan cable , rebooted,edited the file , again rebooted.. the lan interface is not showing up at all . .i tried connecting web. no use.

Why did you reboot after editting the file. I never said to do that....?

ok, i rebooted cause i didn't see anything happening..what do i do now?

Can you ping your router's internal IP?

here's the set up i have. a desktop running windows which connects to internet via a usb modem. the lan connection i tols is not a broadband, its from my desktop via internet sharing. i dont use any router

Then can you ping the windows PC's internal IP?

no . it says network is unreachable

Can i boot from a live USB and replace my currently installed network manager with that of the live USB ? or can I try update by chrooting ? just a thought . will it work?

Yes, I've done that before, thanks for reminding me. In the live CD, run:

sudo apt-get update
sudo apt-get install network-manager network network-manager-gnome network-manager-pptp network-manager-pptp-gnome

Then if you mount your installed system's partition you can then navigate to /var/cache/apt/archives on the live session and copy the deb files to the installed OS.

You can then reboot and navigate to where you coped the deb files to and run:

sudo dpkg -i ./network*.deb

And the files will be installed :)

Reboot to test

i booted into the terminal and in the live cd session, i pasted ur commands , I got this output...

W: Duplicate sources.list entry cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)/ precise/main i386 Packages (/var/lib/apt/lists/Ubuntu%2012.04%20LTS%20%5fPrecise%20Pangolin%5f%20-%20Release%20amd64%20(20120425)_dists_precise_main_binary-i386_Packages)
W: Duplicate sources.list entry cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)/ precise/restricted i386 Packages (/var/lib/apt/lists/Ubuntu%2012.04%20LTS%20%5fPrecise%20Pangolin%5f%20-%20Release%20amd64%20(20120425)_dists_precise_restricted_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems
ubuntu@ubuntu:~$ sudo apt-get install network-manager network network-manager-gnome network-manager-pptp network-manager-pptp-gnome

in the '/var/cache/apt/archives' of the live cd , there are no deb files . . there's only a folder named 'partial' and a file named 'lock'

Yes, when you upgrade the app it will put the debs from the web in there

i installed the following files 'network-manager-dbg_0.9.4.0-0ubuntu3_amd64.deb' , 'libnl-route-3-200_3.2.3-2ubuntu2_amd64.deb' .. i clicked 'network' under the 'system settings' . .Now it doesn't give any error. my wired and wireless interfaces were disabled. I enabled them and now i'm able to connect internet both via wired and wireless. but the problem is , I still don't see the network manager icon. . it solved my problem partially . . anyone willing to provide remote support via teamviewer.. i think i have a series of other issues too..

now you have connected to the web, run:

sudo apt-get --reinstall install network-manager network-manager-gnome network-manager-pptp network-manager-pptp-gnome

Inviting complete strangers onto your PC is not smart in any way. I strongly advise you not to do this in future.

i was trying to get wicd and messed something up .. now , I get this error about wicd whenever i do a apt-get install package

ajay@ajay-Dell-System-Inspiron-N4110:~/Desktop/aircrack-ng-1.1$ sudo apt-get --reinstall install network-manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 wicd-daemon : Depends: python-wicd (= 1.7.2.3-1) but 1.7.2.3-1ubuntu0.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
ajay@ajay-Dell-System-Inspiron-N4110:~/Desktop/aircrack-ng-1.1$

wget https://dl.dropbox.com/u/8850924/python-wicd_1.7.2.3-1ubuntu0.1_all.deb
sudo dpkg -i ./python-wicd_1.7.2.3-1ubuntu0.1_all.deb
rm ./python-wicd_1.7.2.3-1ubuntu0.1_all.deb
sudo apt-get -f install

HTH

unfortunately ,No. I don't mind removing all traces of wicd altogether. . will that eliminate this error and how to do it ?

Sure, why not

how to remove wicd completely just tell me the commands..

sudo apt-get --purge remove `dpkg -l | grep wicd | awk {'print $2'}`

Will do it

Thanks actionparsnip, that solved my question.

about the missing network icon , try to update the solution when u r free. Thank you !

general technology (gtmaroc) said : #35

thank you sir i flowed answer that is in answer #20, and it's successfully worked form