11.10 upgrade problems

Asked by Winton Roseland on 2011-12-11

I have been trying to get everything working again after the upgrade and I was able to fix most issues this last week. Being without a working system for over a month has been annoying. Currently my system expects to have eth0 and is configured as such. After the upgrade I have eth1 instead. How does this happen and what can I do? I really don't want to change the configuration to use eth1 - I want the system to establish eth0 as the proper device.
Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2011-12-12
Last query:
2011-12-12
Last reply:
2011-12-11
Nathan Heafner (nathan1465-5) said : #1

Hey Winton,
this could mean you have two wired connections on your machine.

please open terminal and post the output of the following command.
route

you can open terminal in ubuntu by pressing CTLR + ALT + T.

also, the command inconfig may be useful for you, but i wouldnt recommend posting the contents of that command here as it may contain information that you dont wish to share.

also look in settings -- network -- wired -- configure .. look at device mac and it should show what eth it is.

and as always, its recommended to be up to date by running

sudo apt-get update
sudo apt-get upgrade

Best Sam_ (and-sam) said : #2

Maybe compare pci-bus-id and mac address from those outputs.
ifconfig -a
lspci -nnk | grep -i net -A2
cat /etc/udev/rules.d/70-persistent-net.rules

In case correct mac address in network-manager and restart.

Winton Roseland (wdaytonland) said : #3

Thanks Sam_, that solved my question.