Ubuntu

0: acer-wireless: Wireless LAN Soft blocked: yes -> DISABLED Wireless interface Intel WiFi Link 5100 not working on Packard Bell Easynote TN-65 in Ubuntu 11.10

Asked by Fidel Nadera on 2011-11-05

I own a wireless card Intel WiFi Link 5100 and I can not get it
working on my laptop. My operating system is Ubuntu 11.10, Kernel
3.0.0.12. I have a Packard Bell Easynote TN-65. Can you tell me how
to solve the problem?

This is part of a correspondence I had with a developer which obviously do not make a name for privacy issues.

Fidel Nadera: Dear Sir,
I own a wireless card Intel WiFi Link 5100 and I can not get it
working on my laptop. My operating system is Ubuntu 11.10, Kernel
3.0.0.12. I have a Packard Bell Easynote TN-65. Can you tell me how
to solve the problem?
Thank you very much

Developer : I would like to have more information then just "not workjng", could
you please elaborate?
thanks

Fidel Nadera: Yes, I'm sorry. When I press the button to activate the wireless card
on my keyboard, does not turn on the light that indicates active tab.
So I thought it was a hardware problem, but then I discovered that it is not.
I tried two other ways to test the card:
1) I went in the menu network (using network manager) and I pressed
the button "enable wireless network" and the card is activated for a
second jack.I tested this procedure several times (50 times). What
happens is that an average of 30 that once the card is active and
recognizes wireless networks(See Picture1.png)
2) I tried another procedure by going to system settings. For this
procedure I attach files in png format with a full explanation. This
is the procedure:
2.1 I clicked the up right botton (switch off button). Then I
clicked "System settings" See Picture2.png.
2.2 I selected "network". See Picture3.png
2.3 I selected "wireless" then I unchecked "airplane mode". See
Picture4.png.
2.4 I tried to select "wireless on". See Picture5.png.
In the second procedure, the problem remains exactly as in the first
procedure.

Developer: I guess I need to explain more, I will like to see the dmesg and
understand what happen, picture could not tell me anything

Fidel Nadera: sorry! I proceeded to send the dmesg I found in the log folder.

Developer: Hmm, the dmesg log you send did not have anything stand-out. Do you have ability to re-compile kernel? I will like to have you re-build the kernel with DEBUGFS option enabled for iwlwifi, then load the iwlagn module with debug=0x43fff. By doing so, it can provide a lot more information in dmesg log.

Fidel Nadera: I checked the kernel configuration file config3.0.0-12-generic in /
>>>> boot. DEBUGS enableb option is for iwlwifi:
>>>>
>>>> #
>>>> # Debugging Options
>>>> #
>>>> Y = # CONFIG_IWLWIFI_DEBUG
>>>> CONFIG_IWLWIFI_DEBUGFS = y
>>>> CONFIG_IWLWIFI_DEVICE_TRACING = y
>>>> # CONFIG_IWLWIFI_DEVICE_SVTOOL is not set
>>>> # CONFIG_IWL_P2P is not set
>>>> CONFIG_IWLWIFI_LEGACY = m
>>>>
>>>> Then I loaded the module iwlagn with the following command:
>>>>
>>>> sudo modprobe iwlagn debug = 0x43fff.
>>>>
>>>> I send you information that can be useful
>>>>
$ dmesg | grep iwlagn
>>>> [26.435423] iwlagn: Intel (R) Wireless WiFi Link AGN driver for Linux,
>>>> in-tree:
>>>> [26.435426] iwlagn: Copyright (c) 2003-2011 Intel Corporation
>>>> [26.435536] iwlagn 0000:03:00.0: PCI INT A -> GSI 17 (level, low) ->
>>>> IRQ 17
>>>> [26.435567] iwlagn 0000:03:00.0: setting latency timer to 64
>>>> [26.435634] iwlagn 0000:03:00.0: Detected Intel (R) WiFi Link 5100
>>>> AGN, REV = 0x54
>>>> [26.454248] iwlagn 0000:03:00.0: device EEPROM VER = 0x11f, 0x4 =
>>>> CALIB
>>>> [26.454252] iwlagn 0000:03:00.0: Device SKU: 0xb
>>>> [26.461280] iwlagn 0000:03:00.0: Tunable channels: 13 802.11bg, 24
>>>> 802.11a channels
>>>> [26.461397] iwlagn 0000:03:00.0: irq 47 for MSI / MSI-X
>>>> [26.691811] ​​iwlagn 0000:03:00.0: RF_KILL bits toggled to enable the
>>>> radio.
>>>> [27.015115] iwlagn 0000:03:00.0: loaded firmware version 8.83.5.1
>>>> build 33692
>>>> [29.424140] iwlagn 0000:03:00.0: RF_KILL bits toggled to disable the
>>>> radio.
>>>> [37.480584] iwlagn 0000:03:00.0: RF_KILL bits toggled to enable the
>>>> radio.
>>>> ubuntu@ubuntu-EASYNOTE-TN65:~$ ifconfig
>>>> eth0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
>>>> UP BROADCAST MULTICAST MTU:1500 Metric:1
>>>> RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>>>> TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>>>> collisioni:0 txqueuelen:1000
>>>> Byte RX:0 (0.0 B) Byte TX:0 (0.0 B)
>>>> Interrupt:45 Indirizzo base:0x6000
>>>>
>>>> lo Link encap:Loopback locale
>>>> indirizzo inet:000.0.0.1 Maschera:000.0.0.0
>>>> indirizzo inet6: ::1/128 Scope:Host
>>>> UP LOOPBACK RUNNING MTU:16436 Metric:1
>>>> RX packets:996 errors:0 dropped:0 overruns:0 frame:0
>>>> TX packets:996 errors:0 dropped:0 overruns:0 carrier:0
>>>> collisioni:0 txqueuelen:0
>>>> Byte RX:75840 (75.8 KB) Byte TX:75840 (75.8 KB)
>>>>
>>>> ppp0 Link encap:Point-to-Point Protocol
>>>> indirizzo inet:000.00.000.000 P-t-P:00.0.0.0
>>>> Maschera:000.000.000.000
>>>> UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
>>>> RX packets:285 errors:0 dropped:0 overruns:0 frame:0
>>>> TX packets:270 errors:0 dropped:0 overruns:0 carrier:0
>>>> collisioni:0 txqueuelen:3
>>>> Byte RX:188223 (188.2 KB) Byte TX:45953 (45.9 KB)
>>>>
>>>> usb0 Link encap:Ethernet HWaddr 00:00:00:00:00:00
>>>> indirizzo inet6: 0000::00:0000:0000:0d5/64 Scope:Link
>>>> UP BROADCAST MULTICAST MTU:1500 Metric:1
>>>> RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>>>> TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
>>>> collisioni:0 txqueuelen:1000
>>>> Byte RX:0 (0.0 B) Byte TX:90 (90.0 B)
>>>>
$ iwconfig
>>>> lo no wireless extensions.
>>>>
>>>> eth0 no wireless extensions.
>>>>
>>>> wlan0 IEEE 802.11abgn ESSID:off/any
>>>> Mode:Managed Access Point: Not-Associated Tx-Power=15
>>>> dBm
>>>> Retry long limit:7 RTS thr:off Fragment thr:off
>>>> Power Management:off
>>>>
>>>> usb0 no wireless extensions.
>>>>
>>>> ppp0 no wireless extensions.
>>>>
>>>> I attached the latest dmesg log.

Developer: >>> please check your rf switch and make sure WiFi did not get disabled
>>>
>>> you can use the following command to check
>>>
>>> $rfkill list
>>>
>>> Thanks

Fidel Nadera: this is the result:
>>
~$ rfkill list
>> 0: acer-wireless: Wireless LAN
>> Soft blocked: yes
>> Hard blocked: no
>> 1: phy0: Wireless LAN
>> Soft blocked: no
>> Hard blocked: no
~$
>>
>> the hardware is enabled but does not interact with the network manager.
>> There is a software trouble.

Developer: what happen if you try to unblock by "rfkill"?

Fidel Nadera: This is the result:

~$ sudo rfkill list

0: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
$ sudo rfkill unblock 1
~$ sudo rfkill unblock 0
$ sudo rfkill list
0: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
~$

the problem persists. Is not solved. I allowed myself to try another program to manage wireless cards. I installed "wicd" and the program switches on the card permanently, and recognizes the wireless networks available. It 'likely that the problem is the "network manager". No hardware problem.

Developer: maybe report this to the maintainer of NetworkManager maintainer

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Mark Rijckenberg
Solved:
2011-11-05
Last query:
2011-11-05
Last reply:
2011-11-05

Can you give the output of:

sudo lshw -C network; lsb_release -a; sudo rfkill list

Thanks

 sudo lshw -C network
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 02
       serial: 00:1f:16:0d:15:75
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=N/A latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:45 ioport:3000(size=256) memory:f2010000-f2010fff memory:f2000000-f200ffff memory:f2020000-f203ffff
  *-network DISABLED
       description: Wireless interface
       product: WiFi Link 5100
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 00
       serial: 00:21:5d:5e:65:f6
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-12-generic firmware=8.83.5.1 build 33692 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
       resources: irq:46 memory:f2100000-f2101fff
  *-network
       description: Ethernet interface
       physical id: 4
       logical name: usb0
       serial: 01:fd:03:49:09:d5
       capabilities: ethernet physical
       configuration: broadcast=yes driver=cdc_ether driverversion=22-Aug-2005 firmware=CDC Ethernet Device link=no multicast=yes

sudo lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

sudo rfkill list
0: acer-wireless: Wireless LAN
 Soft blocked: yes
 Hard blocked: no
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

Is there a key combo or switch to disable / enable wireless? If so, press it. If it is no good, run:

sudo rfkill unblock all

May help

Please copy-paste the following command into the Terminal and then press
<ENTER>:

gksudo gedit /etc/modprobe.d/blacklist.conf

Using the gedit editor, please ADD the following configuration line into
the file /etc/modprobe.d/blacklist.conf:

blacklist acer_wmi

Using the gedit editor, SAVE the change to the

/etc/modprobe.d/blacklist.conf file.

Then REBOOT and retest wireless. This blacklist operation should make
the change permanent, even after rebooting.

This should force the Linux kernel to stop loading the acer_wmi module,
which is probably causing the kernel to soft block your wireless adapter.

The acer-wireless interface is an invalid wireless interface on your computer, because you are using a Packard Bell Easynote TN-65 , not an ACER computer.

Thanks Mark Rijckenberg, that solved my question.

Nick Mitcham (cpbussm) said : #6

Thanks also to Mark Rijckenberg, that solved the same problem I had in Mint 12 Lisa. I run an Acer One Notebook.

ximo (ximo-y) said : #7

Gracias Mark Rijckenberg, he podido solucionar el mismo problema que tenía hace dos días en mi Ubuntu 12.04 y mi packard Bell Etna tn-65

Thank you.