GREATLY reduce the boot duration of Ubuntu 11.10

Asked by krugerj on 2011-11-01

The present question is related to my earlier question #176980 ("suspend" and "hibernate" do not awake).
How can I CONSIDERABLY reduce the boot duration of Ubuntu 11.10? Actually it is nearly 3 minutes. This was acceptable in 1990 but not today. Why is it so much more than Ubuntu 11.4? Can the elimination of installed software help? Or is the reason another one? Since I do not understand the functions of most of the installed packages, how do I proceed? I want to use Libreoffice, gedit, nedit, pocket calculator, python, Mozilla firefox, a means to see internet movies, Grace for scientific graphic, Kompozer for website generation, Gimp, Gwenview, a program for rapid viewing of fotos, Skype, Brasero, connection to beamer.
No one else will use this computer, no interactions whatsoever via internet or to other computers are desired.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-07
Last reply:
2011-11-07
Ubfan (ubfan1) said : #1

Take a look at your log files, look for the minute gaps and see what is holding things up. Usually, that sort of delay is a timeout of some kind, like wireless trying to set up the n channels, waiting, then giving up and falling back to the g channels. You'd get no disk activity for that sort of problem either. You might have to suppress certain drivers or provide options to select items directly rather than let the computer scan for something that works -- frequently done via blacklisting and providing options in files in /etc/modprobe.d

marcus aurelius (adbiz) said : #2

type is the make and model of your machine? i had a similar problem with the toshiba netbook. it was solved by turning off ahci and enabling sata compatibility.

krugerj (querciop) said : #3

Dear ubfan1 and Marcus Aurelius, thank you for your answers which I cannot understand, however. Yet, I believe that they will be helpful. I cannot believe, after working since 50 years with computers, that I now have to BEGIN to learn how they are organized internally.

I do not know what is /how I can
- a log file
- "things"
- n channels / g channels
- a driver
- suppress a driver
- find out WHICH drivers I have to suppress
- blacklisting
- provide options in files in /etc/modprobe.d
- turn off ahci
- enable sata compatibility

Can you still help me?

Ubfan (ubfan1) said : #4

Computers are a continual learning experience, but local user groups are a good resource to know about. Someone in the group may be able to diagnose/fix a problem in minutes rather than the extended time a mail help interface will introduce.
New to Ubuntu:
- read the Ubuntu Manual, it's very informative: http://ubuntu-manual.org/
Click on the "download Button" to download the latest PDF version.
- The Ubuntu pocket guide: http://www.ubuntupocketguide.com/
- The online help https://help.ubuntu.com

Relax and fun:
http://planet.ubuntu.com/ and Full Circle Magazine http://fullcirclemagazine.org/

For your long boot time, you didn't say what your computer setup is, but I'd only expect a 3 minute boot time from a live install media, but even in that case, three quick carriage returns to get past the video discovery will reduce the boot time to 45 seconds. Checking what is happening at boot time is pretty straightforward. The system log files are kept in /var/log, so just take a look at the latest ones with timestamps in them to see where the holdup occurs. The log files are restarted when they get too big, and eventually compressed, then deleted, so if a log file is empty, look at the next older one which is given a .1 suffix. The first one I'd check is daemon.log, which should have the wireless setup, and which is good candidate for causing problems.

krugerj (querciop) said : #5

Question #177104 Dear Ubfan, in Ubuntu 11.10 there is no daemon.log but the relevant logfile seems to be /var/log/syslog. The relevant logfile section after my computer start begins with the time stamp "Nov 7 11:11:51". Many lines follow, the last line before the occurrence of the waiting times is
Nov 7 11:11:53 Zeki udev-configure-printer: add /module/lp
Thereafter I believe are the 4 lines that show the waiting times:
Nov 7 11:11:53 Zeki udev-configure-printer: Failed to get parent
Nov 7 11:12:27 Zeki pppd[844]: Timeout waiting for PADO packets
Nov 7 11:12:27 Zeki pppd[844]: Unable to complete PPPoE Discovery
Nov 7 11:13:32 Zeki pppd[844]: Timeout waiting for PADO packets
Nov 7 11:13:32 Zeki pppd[844]: Unable to complete PPPoE Discovery
From here on the computer seems to continue normally:
Nov 7 11:13:51 Zeki kernel: [ 140.326104] type=1400 audit(1320660831.820:7): apparmor="STATUS" operation="profile_load" name="/usr/lib/lightdm/lightdm-guest-session-wrapper" pid=898 comm="apparmor_parser"
.......

Can you help me? Can you tell me what I have to do in order to eliminate these waiting times? This time when starting the computer I had the WLan (Wifi) switch on my computer turned off but this seems to make no difference for the waiting times. Best wishes Jürgen Krüger
___________________________________________________________
SMS schreiben mit WEB.DE FreeMail - einfach, schnell und
kostenguenstig. Jetzt gleich testen! http://f.web.de/?mc=021192

Ubfan (ubfan1) said : #6

Looks like you have discovered a timeout on attempting to establish a PPP conection. Do you have a modem which is only on occasionally but is configured to connect automatically? Look under the network-manager/edit connections and see what is under the Mobile Broadband tab -- check that any connection there does not have the "connect automatically" box checked (or just delete the connection if it is unused). If that is not your problem, better repost the question for a PPP issue, I don't use it myself.

Can you help with this problem?

Provide an answer of your own, or ask krugerj for more information if necessary.

To post a message you must log in.