ssid of wifi network in network manager changes on its own

Asked by iceman8958 on 2011-10-24

version : ubuntu 11.10
Every time i connect to my wifi network
the ssid in the network manager changes on its own to "õ"
then i have to edit again to the name of the network.
After correcting, it connects.

But the change only last till my next reboot.
after reboot i have to do this again

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-10-25
Last query:
2011-10-25
Last reply:
2011-10-24

Can you give the output of:

lsb_release -a; dpkg -l | grep network

Thanks

Paulus (paul-schouten) said : #2

I've got a similar problem on my 64 bit Ubuntu 11.10 (clean install). See attached screenshot on Flickr: http://www.flickr.com/photos/68462644@N06/6277345082/

For your information: here's my output for "lsb_release -a; dpkg -l | grep network":

paul@Brown:~$ lsb_release -a; dpkg -l | grep network
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
ii avahi-autoipd 0.6.30-4ubuntu1 Avahi IPv4LL network address configuration daemon
ii glib-networking 2.30.0-0ubuntu1 network-related giomodules for GLib
ii gnome-nettool 3.0.0-0ubuntu2 network information tool for GNOME
ii gwibber 3.2.0.1-0ubuntu1 Open source social networking client for GNOME
ii gwibber-service 3.2.0.1-0ubuntu1 Open source social networking client for GNOME
ii ifupdown 0.7~alpha5.1ubuntu5 high level tools to configure network interfaces
ii iproute 20110315-1build1 networking and traffic control tools
ii iputils-ping 3:20101006-1 Tools to test the reachability of network hosts
ii iputils-tracepath 3:20101006-1 Tools to trace the network path to a remote host
ii libnm-glib-vpn1 0.9.1.90-0ubuntu4 network management framework (GLib VPN shared library)
ii libnm-glib4 0.9.1.90-0ubuntu4 network management framework (GLib shared library)
ii libnm-gtk-common 0.9.1.90-0ubuntu6 network management framework (common files for wifi and mobile)
ii libnm-gtk0 0.9.1.90-0ubuntu6 network management framework (GNOME dialogs for wifi and mobile)
ii libnm-util2 0.9.1.90-0ubuntu4 network management framework (shared library)
ii libqt4-network 4:4.7.4-0ubuntu8 Qt 4 network module
ii net-tools 1.60-23ubuntu3 The NET-3 networking toolkit
ii netbase 4.45ubuntu3 Basic TCP/IP networking system
ii network-manager 0.9.1.90-0ubuntu4 network management framework (daemon and userspace tools)
ii network-manager-gnome 0.9.1.90-0ubuntu6 network management framework (GNOME frontend)
ii network-manager-pptp 0.9.0-0ubuntu2 network management framework (PPTP plugin core)
ii network-manager-pptp-gnome 0.9.0-0ubuntu2 network management framework (PPTP plugin GNOME GUI)
ii oneconf 0.2.6.7 synchronize your configuration data over the network
ii tcpdump 4.1.1-2ubuntu2 command-line network traffic analyzer

Could try wicd

Paulus (paul-schouten) said : #4

I'm sorry for the double/cross post, but I think I've found a solution: probably you're using a numeric SSID. I've changed my (numeric) SSID from "12" to "Twaalf" (that's Dutch for Twelve). Now network manager loads the correct SSID from it's config file(s).

See bug: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/874328

iceman8958 (iceman8958) said : #5

Thanks every one.
@Paulus you are right i was using a numeric ssid.
changed it to a character string and everything is working fine.

iceman8958 (iceman8958) said : #6

Thanks

iceman8958 (iceman8958) said : #7

Thanks actionparsnip, that solved my question.