Network manager shows device not managed

Asked by VP Gautham on 2011-09-14

I am using ubuntu 11.04...I installed Gnome shell in my system...and after installing gnome shell nm-applet in my notification area went missing and my login screen looked to old style. Also i did not get the login screen application. So i uninstalled gnome shell after googling for sometime for getting help in uninstalling gnome shell...now i can see nm-applet in noti area but it shows wired network device not managed .......how to get it right.......

Pls Help guys...............

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-09-15
Last query:
2011-09-15
Last reply:
2011-09-15

Can you give the output of:

sudo lshw -C network; lsb_release -a; uname -a; sudo rfkill list

Thanks

VP Gautham (vpgautham) said : #2

Thanks for the response
 Here is the output of what you said

toshiba@toshiba-Satellite-L300:~$ sudo lshw -C network; lsb_release -a; uname -a; sudo rfkill list
   *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 02
       serial: 00:1e:33:b7:41:52
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.1.115 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:43 ioport:3000(size=256) memory:90410000-90410fff memory:90400000-9040ffff memory:90420000-9043ffff
  *-network
       description: Wireless interface
       product: AR5001 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 01
       serial: 00:24:d2:6f:bd:33
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=2.6.38-8-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bg
       resources: irq:17 memory:94600000-9460ffff
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
Linux toshiba-Satellite-L300 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:50 UTC 2011 i686 i686 i386 GNU/Linux
0: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

Try:

sudo modprobe -r ath5k; sleep 4; sudo modprobe ath5k

May help

VP Gautham (vpgautham) said : #4

got it man.......!!!! Thanks.....!!!

VP Gautham (vpgautham) said : #5

Thanks actionparsnip, that solved my question.

Does it work after a reboot?

VP Gautham (vpgautham) said : #7

After trying your command nothing happened but when i reboot it works well.........!!

Cool