bcmwl5 wifi driver causes eth0 port to not be recognized

Asked by Wade Holen on 2011-07-13

Info: Dell inspiron e1505 laptop. Latest ubuntu version as of july 2011. Wifi card is a Minicard wlan 1390. also have eth0 port

Problem: driver needed to activate wifi card is bcmwl5.....when i install the driver and restart wlan0 works fine but the eth0 is not recognized in terminal with the 'ifconfig' or 'iwlist scanning' commands. I can get eth0 to work by uninstalling the driver and restarting.

However i need both connections to work at same time so i can share the network with my desktop. WHAT DO I DO?

I have tried: restarting, reinstallin OS, uninstalling and reinstalling drivers, i tried Linux mint...had same problem, i have tried different network managers.... but still no luck

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Wade Holen
Solved:
2011-07-13
Last query:
2011-07-13
Last reply:
2011-07-13

Can you give the output of:

sudo lshw -C network; cat /etc/lsb-release; rfkill list

Thanks

Wade Holen (holenwade) said : #2

wade@wade-MM061 ~ $ sudo lshw -C network; cat /etc/lsb-release; rfkill list
[sudo] password for wade:
PCI (sysfs)

Give it time, the PCI bus is slow

Wade Holen (holenwade) said : #4

oops i copied to soon therre was more....

wade@wade-MM061 ~ $ sudo lshw -C network; cat /etc/lsb-release; rfkill list
[sudo] password for wade:
  *-network
       description: Wireless interface
       product: BCM4311 802.11b/g WLAN
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:0b:00.0
       logical name: wlan0
       version: 01
       serial: 00:1a:92:7f:5d:57
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ndiswrapper+bcmwl5 driverversion=1.56+Broadcom,10/12/2006, 4.100. ip=192.168.1.100 latency=0 link=yes multicast=yes wireless=IEEE 802.11g
       resources: irq:16 memory:efdfc000-efdfffff
  *-network UNCLAIMED
       description: Ethernet controller
       product: BCM4401-B0 100Base-TX
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=64
       resources: memory:ef9fe000-ef9fffff
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=11
DISTRIB_CODENAME=katya
DISTRIB_DESCRIPTION="Linux Mint 11 Katya"
0: dell-wifi: Wireless LAN
 Soft blocked: no
 Hard blocked: no
1: dell-bluetooth: Bluetooth
 Soft blocked: no
 Hard blocked: no

Wade Holen (holenwade) said : #5

as u can c im actually on linux right now but same problem is on ubuntu

Linux Mint isn't supported here or in any of the Ubuntu channels. You are using Mint which is supported here:
http://forums.linuxmint.com/

Wade Holen (holenwade) said : #7

wow.... mint hater

No, just that Mint isn't supported in any of the Ubuntu methods. You aren't using Ubuntu so you have simply posted in the wrong place. I never said I hated mint at any point.

Wade Holen (holenwade) said : #9

ok well i was kinda joking anyway. so i posted it in linux forum now.....but i swear it is the exact same problem. and i have dual boot right now linux and ubuntu. exact same thing happens in both

Wade Holen (holenwade) said : #10

i mean linux mint when i say linux btw... iknow both are linux!