eth0 and wlan0 not working simultaniously

Asked by Wade Holen on 2011-07-11

I have read and tried similar solutions, but cannot get them to work.
I have a dell inspiron laptop E1505 with minicard 1390 wifi card and a ethernet port
i am trying to get internet to my laptop with wifi and then connect to desktop with ethernet cable to share with the laptops internet connection with desktop

this laptop running ubuntu 10.somthing seems to drop wlan0 when i get eth0 to work and drops eth0 when i get wlan0 to work

I am not extremely skilled in terminal so if giving terminal commands please give exact words and spacing for every entry.

I really need this to work, cuz i have no other way of getting internet to my desktop right now. I just build a custom gaming rig and i cant play EVE online until i get this connection going. Tis urgent. :*(

wade@wade-MM061:~$ ifconfig
lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:20 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1200 (1.2 KB) TX bytes:1200 (1.2 KB)

wlan0 Link encap:Ethernet HWaddr 00:1a:92:7f:5d:57
          inet addr:192.168.1.100 Bcast:192.168.1.255 Mask:255.255.255.0
          inet6 addr: fe80::21a:92ff:fe7f:5d57/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:5823 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6173 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5285756 (5.2 MB) TX bytes:993712 (993.7 KB)
          Interrupt:16 Memory:efdfc000-efe00000

wade@wade-MM061:~$

(i can get it to do eth0 too sometiems.... so i know they both work) not a hardware problem here

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-11
Last reply:
2011-07-11
Duncan Thomas (luciomrx) said : #1

There are hard way to do it but here's simple one.
Try to install wicd. it is another network manager that allows you to connect them at the same time.
terminal > sudo apt-get install wicd-gtk
for your wired should be fill with eth0
for your wireless should be wlan0
I guess why NM in Ubuntu doesn't allow to connect the same time, it is probable security reasons.

Wade Holen (holenwade) said : #2

Ok i installed that program and added eth0 but it still doesnt recognize my ethernet port...only the wifi right now.
When i plug in the ethernet cable the light does not light up on the port either. The cable is already plugged into my desktop and i know that connection is good.

Wade, NetworkManager can share your ethernet and wifi without issues, provided it is correctly configured. What you will likely want is to first remove all of the connections you may have created in the connection editor for wifi and eth0, then rebuild your wifi connection with standard settings (e.g. click the network name in the list, enter the password if there is one, and that's it). For the ethernet connection, create a new one (because otherwise you'll always need to modify the default depending on whether you want to share or connect elsewhere with a wire), and make sure the drop-down for Method under the IPv4 tab is set to "Shared with other computers".

Wade Holen (holenwade) said : #4

I dont know how but i had it working before on linux mint 10 with this computer.... so i know its possible

now i connect the cable in laptop and it lights up....but the laptop doesnt recognize it unless i uninstall my STA wireless drivers and reboot. but when i do that then my wifi doesnt work!! so i can get eth0 up or wlan0 up.....but not at same time. and i know others have had this problem....it is very frustrating:/

Then this definitely sounds like a race condition in loading drivers, so I'll convert this back into a bug against the kernel ("linux").

Can you help with this problem?

Provide an answer of your own, or ask Wade Holen for more information if necessary.

To post a message you must log in.