How to debug nm-dispatcher not calling 01ifupdown

Asked by alainpannetier on 2011-02-25

Dear all,

I've got two Ubuntu laptops (both 10.10) both v 0.8.1.

"NetworkManager (version 0.8.1) is starting..."

One is a new Maverick install and the other has been upgraded many times since 9.04.

On the latter, setting up a custom script hook in adding 'touch /a.txt' at the top of /etc/NetworkManager/dispatcher.d/01ifupdown worked instantaneously. When the Wifi switch is pressed or the Applet disconnect option is selected, the a.txt file shows up under /

However, on the older laptop, I can't get nm-dispatcher to get called, or at least to execute its hooks. The same test yields nothing.

I've tried to run

NetworkManager --no-daemon -log-level=DEBUG

But there is no mention of nm-dispatcher in the output.

How can I

   1. Have a look at the source (I looked into the git repo but could not find where the source for the dispatcher lives).
   2. Find why the nm-dispatcher never gets called.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu network-manager Edit question
Assignee:
No assignee Edit question
Last query:
2011-02-25
Last reply:
2011-02-25

You might want to try start NetworkManager the following way:

sudo /usr/sbin/NetworkManager --no-daemon --log-level=DEBUG --log-domain=CORE

However, to figure out why the dispatcher doesn't run hooks on your system, make sure any file in /etc/NetworkManager/dispatcher.d/ is set as executable (permissions rwxrwxr-x or something similar), and that there is nothing at the beginning of a script to stop it from executing in certain specific conditions.

Can you help with this problem?

Provide an answer of your own, or ask alainpannetier for more information if necessary.

To post a message you must log in.